I've got retropie 3.8 installed with kodi running

I've installed kodi via:

  1. sudo apt-get update

  2. sudo apt-get install kodi (currently 15.2)

  3. identified controller via cat /proc/bus/input/devices (8BitDo SNES30 GamePad)

  4. defined new joystick.xml under /home/pi/.kodi/userdata/keymaps/ with the same name and basic mappings e.g.

    <joystick name="8BitDo SNES30 GamePad">
    <button id="1">Select</button>
    <button id="0">Back</button>
    <axis id="1" limit="-1">Up</axis>
    <axis id="1" limit="+1">Down</axis>
    <axis id="2" limit="-1">Left</axis>
    <axis id="2" limit="+1">Right</axis>
  1. start Kodi (sudo kodi)

  2. Joystick isn't registered

If I look at the kodi.log under /home/pi/.kodi/temp/ I can see that SNES30 is attempting to be mapped via dev/input/event3 which is not right (it should be js0)

  • Rather than using cat /proc/bus/input/devices you can simply run evtest and then select your registered device - very useful for testing the buttons work etc.
    – schlock
    Commented Aug 11, 2016 at 13:14

1 Answer 1


Good news: I've almost got it working. It turns out that v3.8 of retropie (with upgraded settings) only includes 15.2 of Kodi with joysticks not compiled in it. Current apt-get didn't have any newer versions of Kodi and so I:

  1. Add experimental repository of Kodi for raspbian (currently 16.1)

echo 'deb http://pipplware.pplware.pt/pipplware/dists/jessie/main/binary /' | sudo tee --append /etc/apt/sources.list.d/pipplware_jessie.list

  1. Add repository key

wget -O - http://pipplware.pplware.pt/pipplware/key.asc | sudo apt-key add -

  1. Update apt-get

sudo apt-get update

  1. Uninstall old kodi

sudo apt-get remove kodi

  1. Install new kodi

sudo apt-get install kodi

This rendition of kodi includes joystick support. the joystick map mostly works although the next conundrum is that only left/down currently works even though it should work - the other button mappings work fine, though.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.