0

I'm the owner of 5 Raspberry boards. Four of them work flawless. The fifth board regularly refuses to respond to pings or SSH. Sometimes it comes up after a few minutes waiting. It has no firewall active. Regularly the board goes into a state of the 'blinking green LED' and responds never again without restarting. The blinking green LED problem appears to be related to power issues but the power supply I use does not cause any trouble on any of the other boards. This troublesome board and two of the others, all of them type 2 boards come from Element14 and all of them run Raspbian installed on identical SD cards. I wonder if there are any bad boards or a batch of bad boards around. Any other suggestions about this issue are welcome too.

  • Have you tried the board with different SD cards? – Mohammad Ali Aug 2 '16 at 18:08
  • Ditto -- you should swap cards/roles with one of the other boards and see if it does the same thing, or indicate in the question if you have already tried this. – goldilocks Aug 2 '16 at 18:12
  • Note that "installed on identical SD cards" does not cover what I meant. I meant, literally take the SD card out of the misbehaving pi and exchange it with one of the others and see which one now does what. You may think you've done nothing wrong, but counting on it is foolish. I'm sure the retailer will replace the pi to save themselves further hassle, but I think you own them the courtesy - and yourself the favour - of at least making some attempt to verify it is not just a difference in configuration etc. And please don't say, "Oh I set them up the same way, no mistakes made by me..." – goldilocks Aug 3 '16 at 5:51
  • Thanks, since my Pi's have different roles I've switched out the boards. Formerly the fileserver (with powered hub and attached hard drive) failed and a mailserver (with no peripherals) was working. After the switch the fileserver keeps currently working and the mailserver fails. So it's still the same board that is failing. – wie5Ooma Aug 4 '16 at 17:08
1

You've already indicated that you've tried different power supplies, to no avail, but have you attempted running the board with a different (known working) SD card? If you've ruled that out, I would also look at power load. Are you running any USB devices on this board that aren't on the other boards? If not, it's most likely your board, which does happen, although rarely. I would contact Element14 for a replacement.

1

I would agree with the others on the SD card. Sometimes the cheapo SD cards will give you issues - I'd suggest formatting the card before flashing the image, try this: https://www.sdcard.org/downloads/formatter_4/

0

The problem turned out to be an apparently troublesome SD card slot. Every time the slot gets too warm the card apparently looses contact and the system stalls. A few months after asking the question I've moved the OS to a hard disk and left only the boot partition on the card. I didn't do this to solve the problem but only to figure out if it was possible to move the OS at all. Since then I've never experienced a problem with this particular board again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.