2

I know there have been several questions like this but none of them have solved my issue. I just purchased a Raspberry Pi 3 and the WiFi on it is incredibly slow. The Web application is slow and when I did a speed test in the browser it returned 80 Kbps.

I tried to just do a wget on a large file and it was fairly consistent at 1 Mbps, which is much better, but still not great. It's not a long way away from my router and has one wall in between the two. I really don't know what else to try to speed it up.

I'm running Raspbian Jessie and everything is up to date.

  • If you're fully updated on Jessie I'm not sure there's an awful lot to do aside from a thorough signal path evaluation. Eliminate everything that could possibly degrade your bandwidth: Test the router's WiFi with a known working device, evaluate the environment for interference (get away from the microwave), move the Pi closer to the router, move both router and Pi to a known good location, replace the Pi's power supply, test the Pi against other routers in other locations, disable running software, reinstall the OS, etc. etc. etc. – goobering Aug 3 '16 at 10:53
1

make sure power management is off on Pi.

iwconfig

You should see something like this

Power Management:off

If not, you can switch it to off by using

sudo iwconfig wlan0 power off

If you want to make this permanent you should add the following line to /etc/rc.local (explanation here):

iwconfig wlan0 power off
  • @loki Please take note that using /etc/rc.local has limitations due to Compatibility with SysV. We have seen many problems here on this site using it. Following the recommendation of the developers from systemd you should avoid using it. – Ingo Mar 21 at 0:18
  • @Ingo thanks for the hint. What would be your preferred solution? – loki Mar 21 at 6:41
  • @loki In general you should use a systemd unit file. In this specific case there is no need to do anything. With journalctl | grep 'power management' you will find raspberrypi kernel: brcmfmac: power management disabled by default. brcmfmac is the wifi driver. – Ingo Mar 21 at 10:03
0

I'm running new Jessie version and I get speed of at least 20 Mbits/sec which is 2 M/s in Mobile carrier speed. I've been using this as a WiFi media server for the last 3 months.

I found that the OS version and the SD card class affects WiFi speed as well as performance. Kindly share your application for further help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.