I'm having some issues with PiFm on the raspberry pi zero - I found this thread but nothing to alleviate my problem. PiFM not working for me

I installed PiFm on a raspi-zero and it seems to be nearly working. I can get only a single tone (or sometimes random sounding noise) on the frequency that I have chosen but nothing is intelligible. I am able to adjust the frequency, so that suggests the hardware is working to some level. I can get some change in the tone based on adjusting the sampling rate but I've ensured I'm matched up with the sampling rate at the high and low end for various sounds.

I'm guessing it might have something to do with the pi-zero vs the regular editions. I am away from home right now so I don't have an o-scope handy or my micro-hdmi to test the regular audio. Just seems like I am missing something fundamental here any near term help would be most appreciated.

I've played the sounds (wav and mp3) on my pc and they seem fine, also i've checked the permissions, gpio status, etc as others have suggested.

Thanks in advance to any suggestions.

  • "I'm guessing it might have something to do with the pi-zero vs the regular editions." -> They are the same in this context except perhaps that power regulation might (I'm not sure) be a little different and hence you might not get as strong a signal. Beware that I think the creators of PiFM abandoned it a long time ago and (this is very much just an opinion) despite much of the hoopla it is really more of an experimental oddity than a practical tool. If you want an FM transmitter for the pi, there are I2C based devices around for $20-25...
    – goldilocks
    Commented Aug 3, 2016 at 5:40
  • ...If you are just doing this to learn some things about low level signal processing, ignore me and good luck ;)
    – goldilocks
    Commented Aug 3, 2016 at 5:40
  • Makezine ran an article called Pirate Radio Throwies that implemented PiFM on a Zero. Might be worth a look for gotchas?
    – goobering
    Commented Aug 3, 2016 at 10:43
  • Thanks @goldilocks , I did see that article previously and not much help there. Just to be sure I ran through it this AM with the same results. One difference at this point is I'm using a newer pizero (1.3) vs the original. I have one of those at home, I'll try out. What you've said basically confirms my suspicions regarding support for pifm. No info out there really and nothing from devs in over 3 years. I'll check out the I2C devices and try my luck with those. I'll leave this post open for now to document the pizero 1.0 vs 1.3 and if anyone else has had success.
    – bk79
    Commented Aug 3, 2016 at 12:57
  • 2
    I will just repost a comment of @scruzz in a related topic: 'Using PiFM is illegal in many countries. It produces terrible radio emissions that bleed all over the radio spectrum. The Raspberry Pi Foundation deletes all posts about it on their forum, and those close to the company/foundation warn that “PiFM / PiRate considered harmful. Do not use.”'
    – SlySven
    Commented Oct 11, 2016 at 4:06

2 Answers 2


I think the issue was one of software, after some more digging I found about 4 or 5 different sources with fm software. I started with this one - http://www.icrobotics.co.uk/wiki/index.php/Turning_the_Raspberry_Pi_Into_an_FM_Transmitter and that is where I was running into issues. I found this other git that worked the first time, maybe due to compiling locally https://github.com/somu1795/fm_transmitter Confirmed this works on both versions of the raspi-zero (1.2 and 1.3) haven't tested big raspis yet. Thanks to everyone who commented. I'll update if I learn anything else

If anyone can figure out the software issues, I'll choose your answer - otherwise I'll just leave this here. Thanks again!

  • Also, as @goldilocks mentioned, this software was more of a gimmick and cool one-off project then something well supported. I did find this transmitting software for the raspberry pi that has a lot more capabilities and is being kept up to date github.com/F5OEO/rpitx
    – bk79
    Commented Aug 4, 2016 at 15:24

Powering the pi zero over gpio didn't work for pifm for me same device 1.3 powered over the mini USB and pifm works.d

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.