2

I want to install Google Cloud SDK as I plan to use Google Voice API for a speech recognition project. However, I would like to inform me about a proper installation process. I tried to follow the steps in Google's installation documentation for Debian and Ubuntu systems. The line I used in the command prompt is:

sudo apt-get update && sudo apt-get install google-cloud-sdk

However after the update the terminal shows the lines below:

W: Failed to fetch http://packages.cloud.google.com/apt/dists/cloud-sdk-jessie/InRelease Unable to find expected entry 'main/binary-armhf/Packages' in Release file (Wrong sources.list entry or malformed file)

E: Some index files failed to download. They have been ignored, or old ones used instead.

At this point I don't know what to do. There is also a Linux installation guide but I'm not sure if that would be suitable for Raspbian Jessie.

I would be grateful for any help. Thank you for your comments in advance.

3

W: Failed to fetch http://packages.cloud.google.com/apt/dists/cloud-sdk-jessie/InRelease

If you go to that page you'll notice near the top:

Architectures: amd64 i386

These refer to what are commonly known as x86-64 and x86 (32-bit) architectures; the vast majority of desktops and laptops now fall into one of these categories.

The Raspberry Pi does not; the Pi A/B/+/0 models are ARMv6, which in Debian nomenclature would equate to armel (Raspbian refers to it as armhf, because it is a bit beyond Debian's armel but, beware, behind their actual armhf); the Pi 2 is ARMv7 (Debian's armhf), the Pi 3 is ARMv8 64-bit (aarch64). These are backward compatible which is why there is only one version of Raspbian which works on all models.

Point being, unless the source for this is available and you can compile it yourself, you are out of luck -- they don't have a binary package available for the platform.

By the looks of this, as of late May 2016 implementing support for the Pi is still "currently with [Google's] engineering team".

  • Thank you for your reply! However, later I installed it by downloading Linux x86 file (google-cloud-sdk-120.0.0-linux-x86.tar.gz) directly from Google SDK site and now it works. But when I do apt-get update it still gives the same error. It seems that the package is still hanging around somewhere. I'm a linux newbie so any help would be greatly appreciated to eliminate this problem. Thanks again! – pandisvezia Aug 4 '16 at 12:57
  • It is impossible to run x86 software on the Pi. Period. Like if someone said, "Oh I just filled the gas tank in my car with milk it runs fine" -- not possible. However, if that package is pure python (a lot of it looked to be, and the parts that aren't may have correlates that are already installed), then it won't matter (because the python interpreter on the pi is ARM based). In any case, generally stuff installed from tar.gz files isn't tracked by the package manager, but if you added something to a file in /etc/apt (e.g. sources.list) then you should remove that reference. – goldilocks Aug 4 '16 at 13:32
1

As mentioned, there is no pre-compiled binaries for the PI. However, installing from the tar.gz works just as well as from apt-get.

Follow instructions here: "Versioned Archives" https://cloud.google.com/sdk/downloads

1

Try to add the Cloud SDK distribution URI as a package source. There's more information about how to do that on 1. It should work just fine.

  • 1
    Please do include relevant parts of the link into the answer. – Bex Aug 9 '17 at 15:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.