0

I have tried everything except reinstalling RetroPie, because I want to try every last thing, before I spend hours reinstalling all my games and so on. Here it goes:

I bought a screen from AliExpress: http://www.aliexpress.com/item/Pi/32378324026.html - I immediately plugged it in, and now the screen lights up (but it's white).

I followed all the guides I could find, but generally all I had to do was:

Under Advanced Options:
Overscan: disable.
Device Tree: enable.
SPI: enable and load kernel module by default.
Audio: force 3.5mm headphone jack (since HDMI will be disconnected later).

After doing all this, it said:

modprobe: ERROR: could not insert 'spi_bcm2708': No such device

So I read a ton of sites saying I could blacklist 2708 and use 2835 instead, but after trying all the possible things inside /boot/cmdline.txt and all kind of files, but after rebooting literally 30 times, I still haven't gotten the screen to turn on with something.

What can I do? I followed a bunch of guides:

https://learn.adafruit.com/running-opengl-based-games-and-emulators-on-adafruit-pitft-displays/retropie-setup
http://www.circuitbasics.com/setup-lcd-touchscreen-raspberry-pi/
http://diyhacking.com/raspberry-pi-touchscreen-lcd-tutorial/

And so on. Nothing works. What can I do? How can I check if SPI is enabled and I can actually use the screen? I'm really stuck and I would love some help.

Thanks

0

Solved: RPi 2 and 3.95 TFT ili9488

Thanks to @alezbarra I finally got my issue fixed. It took a few hours and about 15 installations of various distibutions, but I finally got it working.

Now to make it work on RetroPie as well...

  • Would you please write an answer describing what you needed to do to get RetroPi working with your system? – NomadMaker Apr 13 '18 at 16:09
  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year. – Ingo Jan 9 at 10:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.