12

I booted up my Raspberry Pi for the first time and I plugged in my USB dongle for my wireless keyboard and mouse. It booted up fine but when I type keys either don't appear on the screen or they appear to stick.

Any ideas how to fix this?

12

This is caused by inadequate power. Use a good power supply and a good power cable. Some cheap cables that work with a cell phone, cannot fully power the R-Pi. Some USB devices require a lot of power: most will have a label showing the voltage and mA requirements. They should be 5v 100mA each max, any more than this they must be used with a powered USB hub. Try unplugging every USB device except the keyboard (you should also note that some keyboards have built in hubs and can try to draw 150mA (Pi can only handle 100mA per USB slot without a hub)). Also, use the latest software. Forum user MrEngman reported some keyboard repeats and wireless hangs until upgrading to the debian6-19-04-2012 kernel, which he reports stable with no problems even with a low TP1-TP2 voltage of 4.65 - 4.68 volts.

From http://elinux.org/R-Pi_Troubleshooting#R-Pi_does_not_respond_to_key_presses_.2F_Keyboard_randomly_repeats_key_presses


EDIT There's a note further down that page about the exact keyboard/mouse you're using:

Some wireless keyboards, for example the Microsoft Wireless Keyboard 800 are reported to fail even though the current drawn by the wireless adaptor is within the R-Pi USB spec limit of 100 mA. This may be a software driver problem.

  • +1 Interesting. I've seen another question like this, but this conclusion was not drawn. – Jivings Jun 20 '12 at 9:31
  • Thanks - I don't have a high quality supply handy to test but I will track one down and update when I do. – Andy Smith Jun 21 '12 at 16:56
  • 2
    I'd like to confirm that the issue wasn't my power supply but my specific keyboard. I replaced it with a different keyboard and it works perfectly. – Andy Smith Oct 4 '12 at 9:35
  • Bluetooth keyboards typically use encryption to communicate. Could this additional overhead be causing the bottleneck? – earthmeLon May 21 '13 at 19:38
1

The link @Simon provided in the other answer contains very useful information about this issue. What solved the problem for me is the paragraph just after the one Simon have quoted:

One suggested remedy to this, which has some positive feedback, is to adjust the USB bus speed. To do this, you need to edit the cmdline.txt file, and add "dwc_otg.speed=1" (without quotes) to the end of the file (found in the /boot directory).

You will not be able to do this on the Pi of course because the keyboard itself is crazy. You will have to insert the SD card in your computer and do the necessary edits. This WORKS for my Microsoft Wireless Keyboard 800.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.