15

I am running Raspbian Jessie on Raspberry PI 2 Model B along with a touchscreen. I just noticed that whenever I use the touchscreen display, mouse pointer also follows my finger tips. I don't want that. I want to be able to permanently hide the mouse pointer whenever I am using the touchscreen and be able to get it back whenever I want the mouse pointer.

I keep reading about unclutter program to hide the mouse pointer, but it doesn't totally hide the mouse pointer. As long as you don't touch the screen or move the mouse, the mouse pointer is hidden by the unclutter program, but when you do it shows the pointer. At least that's what I read.

Any idea?

6
  • 2
    I've seen you on a similar question that i answered can you try running the following can you try running it like this starts -- -nocursor Aug 5 '16 at 7:27
  • Yea, but it didn't work.
    – ThN
    Aug 8 '16 at 21:26
  • 2
    i meant to say startx -- -nocursor also, have you tried using unclutter and simply setting the time to zero? Aug 8 '16 at 21:27
  • i read about unclutter and it says that it only makes the cursor disappear momentarily not permanently. If there is no mouse movement, pointer appears. If not, it disappears after sometimes. I don't want any mouse pointer at any one time just like on the smartphones.
    – ThN
    Aug 8 '16 at 21:31
  • 2
    editing the /etc/lightdm/lightdm.conf file. Find the line which starts with xserves-command and edit it to start the X server without cursor. and make it look like this xserver-command=X -nocursor then reboot and startx Aug 8 '16 at 21:43
19

I simply added a nocursor option as follows in the file (/etc/lightdm/lightdm.conf)

xserver-command = X -nocursor

and it worked as it should. No cursor is displayed whatsoever. You can still put your finger on the touch screen and do what you normally do with your mouse pointer; Clicking and Dragging.

2
  • I do want to point out that this answer only seem to work on pitft DISPLAY raspberry pi operating system. I tried this on a regular raspberry PI operating system and it did not work for reason.
    – ThN
    Sep 18 '17 at 20:33
  • 3
    Make sure to add it at the bottom in the [Seat*] section, not above that. Dec 6 '17 at 18:42
4

To work with any X server (I'm using the stretch version), Edit the /usr/bin/startx file and change the defaultserverargs line to: defaultserverargs="-nocursor"

1

An alternative would be to install unclutter and set it to idle 0:
This would disabled the mouse pointer when using a touch-screen.

sudo apt-get install unclutter
unclutter -idle 0

This could be made permantent by adding unclutter to the session:
vi ~/.config/lxsession/LXDE-pi/autostart
and add
@unclutter -idle 0

0

If you use Raspbian Lite without X server, type:

export SDL1_VIDEODRIVER=“dispmanx” 

And run fuse.

The emulator gains performance, and the cursor is hidden.

1
  • Is there any indication the OP runs the PI without X?
    – RalfFriedl
    Mar 9 '19 at 12:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.