0

I installed WebIOPi on my Raspberry Pi 3, I use the patch for Pi 2 and 3 from this Github repository: https://github.com/doublebind/raspi. I can run the WebIOPi service, and the webpage appears in my browser, but the buttons don't do anything.

When I initiate the service, it's suppose to appear a lot of scrolling data about what is happening, but in this case, some of that information starts to appear, but then it just stops.

Also, I know everything about the ports and how they changed, but I get the same result. I am trying to communicate with pins 8 and 10 (TX and RX).

What can I do?

EDIT: Another curious thing is that I run this command sudo /etc/init.d/webiopi status to see if the service is running or not. I get this:

webiopi.service - WebIOPi Loaded: loaded (/etc/systemd/system/webiopi.service; enabled) Active: failed (Result: signal) since Thu 2016-08-04 16:15:45 UTC; 23min ago Process: 412 ExecStart=/usr/bin/python3 -m webiopi -l /var/log/webiopi -c /etc/webiopi/config (code=killed, signal=KILL) Main PID: 412 (code=killed, signal=KILL)

But I can see my html project, but with no response.

  • can you share your /etc/webiopi/config file. Maybe there could be some problem there. – Shan-Desai Aug 4 '16 at 17:20
0

I managed to get response from the html webpage by modifying the Javascript code, but I don't really know why was that the problem. It worked perfectly in my Raspberry Pi 2.

The thing is that the patch for the Raspberry Pi 3 works fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.