0

I am trying to set a static IP address on my RPI, which is working, but I have no internet access. It is connected directly to my router via a cat5 cable. I was using my WIFI, but it seemed to lose connection within 5 minutes. I have had a lot of problems with my RT5370. I don't mind using Cat5 due to the location, and less issues.

My windows PC shows the following info:

IPv4 Address: 192.168.0.2
Subnet Mask 255.255.255.0
Default Gateway 192.168.0.1
DHCP Server 192.168.0.1
DNS Servers 75.114.81.1
            75.114.81.2

My /etc/network/interfaces on the pi shows:

auto lo
iface lo inet loopback

auto eth0
allow-hotplug eth0
#iface eth0 inet manual
iface eth0 inet static
address 192.168.0.11
netmask 255.255.255.0
network 19.68.0.1
gateway 192.168.0.1
dns-nameserver 75.114.81.1

auto wlan0
#allow-hotplug wlan0
#wireless-power off
#iface wlan0 inet static
#address 192.168.0.222
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
wireless-power off

#auto wlan1
#allow-hotplug wlan1

What am I doing incorrectly? I can ping between devices, but no access to google, saying "Unable to display this website. No address associated with hostname"

Any help is greatly appreciated! Thanks

1

"What am I doing incorrectly?" I assume apart from setting a static IP address 😉 and the obvious typing errors in your file.

See How do I set up networking/WiFi/Static IP

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.