How do I change the keyboard layout for the Raspberry PI login screen?

After booting Raspbian, I changed the keyboard layout to Programmer's Dvorak and updated my password. Then I updated my shell to ZSH and logged out to see the changes take effect.

When I get to the login screen, I see that the keyboard defaults back to USA. [facepalm]

Unfortunately my password is long, and I don't want to have to learn to type it in another layout. Is there a way to change the keyboard layout for the Login screen?

  • 1
    Tried sudo raspi-config yet? Aug 6, 2016 at 8:17
  • Although it's not substantial to your question, it might be worth noting that there are US, UK, etc. versions of a Dvorak keyboard, so the default you are referring to here isn't what you think it is (presumably you mean qwerty, or "standard 104-key PC", etc). The initial default on Raspbian is actually a UK keyboard (which isn't about layout so much as it is the content of a few particular keys). As Kong Chun Ho implies, you haven't said how you changed the keyboard layout, which makes it more difficult to suggest an alternative.
    – goldilocks
    Aug 6, 2016 at 12:19
  • Also worth noting, if the change is something that you expected to affect a login session or a particular user's configuration -- saying "logged out to see the changes take effect" implies that -- they of course it won't apply to the login screen, because that user is not logged in. If the change is something that is supposed to apply to the system as a whole, I believe changing the keyboard may requires a reboot (although unplugging it and plugging it back in may also work, I'm not sure).
    – goldilocks
    Aug 6, 2016 at 12:26
  • I ended up uninstalling the GUI anyway and just using sudo raspi-config as Kong Chun Ho suggested. It is nice that RP3 comes with Programmers Dvorak out of the box. Installing it on the original PI was quite a process!
    – f1lt3r
    Aug 7, 2016 at 4:16
  • 1
    Possible duplicate of change keyboard layout in console
    – Fabian
    May 13, 2018 at 20:36

1 Answer 1


I can confirm that changing the keyboard layout in sudo raspi-config > Localisation Options > Change keyboard layout works for the login screen. Just did it. Bothers me to have to figure out my password in QWERTY too.

raspi-config - Raspberry Pi Documentation

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.