I want to set up a wifi direct connection between my phone and my pi3. I followed this post Connect to Raspberry PI 3 over Wi-Fi direct hoping i would be at least able to see my phones open wifi direct connection, but the wpa_supplicant wont start, reporting either

Could not read interface p2p-dev-wlan0 flags: No such device


Failed to create interface p2p-dev-wlan0: -16 (Device or resource busy)

iw list tells me

* P2P-client     
* P2P-GO     
* P2P-device

are all available, which is of no suprise since most tech spec descriptions of the pi3 list wifi direct capabilities...

in my search for answers I stumbled across some people saying "it's a wpa_supplicant 2.5 bug, downgrade your wpa_supplicant" but im no able to find a arm version of the wpa_supplicant 2.3 anywhere. I did find some 2.3 packages in the Archlinux Rollback Machine, but pacman dismissed those as "wrong architecture".

Anyone got any ideas how to solve this?

ps: i got raspbian installed on another sd-card, almost the same problem

edit: Raspbian got wpa_supplicant 2.3, I started the wpa_supplicant with these configs


(just like Van Coding in his post) The wpa_supplicant started, but p2p_find and p2p_listen wouldn't produce any results at all. Extended debug informations revealed

nl80211: Do not indicate P2P_DEVICE support (p2p_device=1 driver param not specified)

so I added


to the params, which, in turn, lead to

Failed to create interface p2p-dev-wlan0: -16 (Device or resource busy)
nl80211: Failed to create a P2P Device interface p2p-dev-wlan0
P2P: Failed to create P2P Device interface

again, Indicating some other problem than a faulty wpa_supplicant release

3 Answers 3


I had the same problem. Then I found that a wpa_supplicant process was already started at boot time to connect to public WIFI. This is why there is the "resource busy" error message. I did a sudo killall wpa_supplicant and retried my wpa_supplicant command, and it worked. Hope this helps.

  • Works perfectly.
    – gilbert-v
    Oct 10, 2019 at 11:48
  • For some reason, this didn't quite work for me. It immediately respawned the process. I had to systemctl restart wpa_supplicant.service, then run the wpa_supplicant command again. It worked after that. Aug 4, 2020 at 19:42

I had the same problem, What I did was download the source for wpa_supplicant from their website wpa_supplicant source for arm. they have instructions on that site for building it as well. making it failed a bunch of times for me because I was missing dependencies like libssl-dev, libncurses-dev and libreadline-dev so after I got that squared away the errors went away, but it still wouldn't connect until after I rebooted, then everything worked.


I also have alarm on the RPi3 and followed this wiki to establish a wireless connection. I used netctl (installed by default on alarm), but there's a lot of other options.

Then I followed the netctl wiki instructions.

Hope it works for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.