0

I'm unable to erase an SDCard (32GB). I've installed NOOBS (Raspberry Pi) on it and run the installation on the device, which result as a files corruption. Well, now I would like to wipe it and retry the installation. I'm unable to do it. I've tried several commands (eraseDisk, sudo eraseDisk, eraseVolume, fdisk, gparted, etc.).

I'm unable to erase the disk (and volume) or replace the partition table.

Using the command : sudo diskutil erasedisk exfat new /dev/disk2

Gives me the error: -69825: Wiping volume data to prevent future accidental probing failed

3
  • Do not cross post. – Milliways Aug 10 '16 at 12:13
  • @Milliways If you notice a cross-post please include a link to it (this mitigates the major issue). Our policy is ambiguous, although S.E. generally frowns on it and many exchanges explicitly forbid it. – goldilocks Aug 10 '16 at 13:08
  • @marren You should not need to bother erasing the card to put an image on it. The image should overwrite what's there from the starting block. If you are using OSX, use dd on the device, not a partition of the device. It doesn't matter whether it contains data that might be considered meaningful in some context or not. You are creating an XY problem. The real issue is either the installation is not being done correctly or the card is defunct. – goldilocks Aug 10 '16 at 13:11
1

Have you tried another SD-Card and/or Card-Reader and/or another Computer? There are multiple reasons why you get this error:

  • the SD-Card is faulty
  • the Card-Reader is broken (I had that once and went mad until I found that error)
  • there is a problem with your System

Nonetheless you can try

sudo dd if=/dev/null of=/dev/rdisk2 bs=1m

to entirely wipe the card. This must work if everything is fine with your equipment.

/dev/rdisk provides raw access and is therefore faster than /dev/disk.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.