1

I got a Raspberry Pi 3 model B a few days ago and have been struggling to get it to work reliably with the latest version of Raspbian. When I try to shut it down or reboot, nothing happens. I have tried

  • Main menu > Shutdown... > Shutdown
  • Main menu > Shutdown... > Reboot
  • sudo shutdown -r now
  • sudo shutdown -h now
  • sudo reboot
  • sudo poweroff
  • sudo halt

For the GUI commands the buttons do nothing at all. For the terminal commands, it looks as if something is executing but nothing is being printed and nothing else happens.

I am reluctant to pull the power physically; I have done that before and apparently something was corrupted, since the next time I powered it on it complained about an EXT4 error and refused to boot fully. I ended up having to reformat and reimage the card.

I am able to log out, but then the options (shutdown, reboot, etc.) in the menu in the top right corner are all grayed out, so that's not helpful.

Edit I'm using the default user (username pi, password raspberry). After running sudo halt -p the log says

Aug 11 17:32:33 raspberrypi systemd[1]: Looping too fast. Throttling execution a little.

Judging by the timestamps this message is being written every 2-3 seconds.

  • 1
    Are you using the Pi user? Have you made any changes to the /etc/sudoers file? Who are you logged in as PI? – Steve Robillard Aug 11 '16 at 15:27
  • Try sudo halt -p then when it does not work (wait about 5 seconds), sudo tail /var/log/syslog and edit in the output above. – goldilocks Aug 11 '16 at 15:29
  • @SteveRobillard Using the default user and I haven't changed the sudoers file. – soapygopher Aug 11 '16 at 15:39
  • What else is running on the system? – Steve Robillard Aug 11 '16 at 16:06
  • 1
    That log message is not a good sign; see if you can extract enough information by looking at the file itself to see what systemd is looping on about. – goldilocks Aug 11 '16 at 16:06
1

I had a similar problem related to a counterfeit SD card which reported an invalid capacity.

The Pi became unresponsive again after a complete shutdown and reboot. The OS was reporting multiple corrupted files, and the µSD card could not be re-formatted.

The problem was that the 'SanDisk µSD' card turned out to be counterfeit. The memory controller IC was reporting the claimed card capacity whilst feeding a much smaller memory chip.

In this case, the true storage size was something larger than 4 GB, but maybe as small as 8 GB. When Raspbian went on to expand itself to the full reported card capacity, the memory controller chip began to send data into oblivion. Hence the large number of 'corrupted files' which were being reported.

I bought a genuine SanDisk card locally, and the Pi now runs fine.

Some notable observations about the fake µSD card, after comparing with a genuine item: The serial number on the back of the fake '64 GB' card was one for a 32 GB device. The serial number was also rotated 90 degrees from that of the genuine card, was not engraved into the material and could be rubbed off. The card was slower than claimed, taking 16 minutes to write Raspbian Jessie, as opposed to 6 minutes when writing to the genuine card. Most of the other discrepancies are hard to spot, even with a magnifying glass.

A normal user of such a fake card might not notice that anything was wrong for quite some time, until trying to retrieve 'stored' data. The deception was revealed quickly only because the µSD card was being used in a Pi.

  • Interesting observations. I have a new card on the way from Amazon so we'll see if a more legitimate one makes a difference. – soapygopher Aug 29 '16 at 16:24
0

Installation and rebooting and everything else worked fine with a better-quality card (Samsung microSDHC UHS-I with 32 GB). I'm willing to chalk the whole thing up to corruption due to a bad card.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.