0

I have a Edimax EW-7811UN wifi dongle, and I'm trying to get it to connect to my wifi when plugged into a raspberry pi zero.

First off, the pi zero has a single usb port so I can only have either my keyboard or the dongle connected, not both at the same time. I tried plugging the dongle into my keyboard's usb port, but then when I check dmesg I see the error:

No support over 100mA

So I'm stuck connecting one device at a time I guess.

My /etc/network/interfaces contains:

auto lo
iface lo

auto wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

My /etc/wpa_supplicant/wpa_supplicant.conf contains:

ctrl_interface=DIR=/var/run/wpa_supplicant
ctrl_interface_group=netdev
update_config=1

network={
    ssid="MYSSID"
    psk="MYPSK"
    proto=RSN
    key_mgmt=WPA-PSK
    pairwise=CCMP
    auth_alg=OPEN
}

Where MYSSID and MYPSK are set to my router's ssid and password.

If I then kick off watch ifconfig, then disconnect my keyboard and connect the dongle, I see a wlan0 entry appear. However, it never gets an ip address, and the RX dropped count slowly increases, but packets, errors, overruns, and frame stay at zero. Also, nothing changes for TX.

Does anyone have any tips for getting this to connect? I've already invested about 8 hours of troubleshooting and trial/error and I'm not sure what to try next.

Other changes I made:

To the file /etc/rc.local

modprobe 8192cu
ifdown wlan0
ifup wlan0

Without the modprobe 8192cu line, the 8192cu driver doesn't load.

I also disabled power saving as described in this question.

  • Can you try using a higher current rating Adapter ? It is strongly advised to use 2 A current rating or more! – Shan-Desai Aug 15 '16 at 8:12
  • @Shan-Desai I ordered another adapter, so I'll report back once it arrives and I get a chance to try it out. – JesseBuesking Aug 16 '16 at 0:11
  • Am I missing something here but what about using a Powered USB hub - that is the recommendation for other RPi models connecting to power hungry USB devices and some WiFi dongles are known to have a current consumption above the 100mA level...? – SlySven Aug 16 '16 at 15:22
  • @Shan-Desai no luck. I'm running it through a 5V 2.4A adapter now, but the results are the same. – JesseBuesking Aug 18 '16 at 4:52
  • 1
    I just realized that the wifi dongle is 2.4GHz only, and the endpoint I was trying to reach was on 5GHz. *facepalm* I switched over to my 2.4GHz endpoint and it's now working, although I'm seeing some bandwidth issues which I'm off to troubleshoot next. – JesseBuesking Aug 24 '16 at 6:48
1

Try this:

Make the section for your wlan0 in /etc/network/interfaces look like this:

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

In your wpa_supplicant.conf file, make it like this:

country=US
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
               ssid="YOUR_SSID"
               psk="YOUR_PSK"
}

Good luck

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.