2

When I go to Menu → Preferences → Raspberry PI Configuration in the GUI there is no link for Raspberry PI Configuration.

3
  • Assuming you mean the config for things like enabling the camera or setting the keyboard layout, you can access them from a terminal with sudo raspi-config. As for why you do not have a link in the gui menu I do not know. Aug 15, 2016 at 19:40
  • Are you using a normal Raspbian Jessie install? If you have upgraded from an older installation the GUI additions are not installed. It is also possible for the Window Manager to become corrupted - it seems very intolerant of errors. If you have not done extensive customisation it may be easier to do a new clean install, rather than try to debug.
    – Milliways
    Aug 16, 2016 at 0:13
  • @Milliways: Thanks. The clean install of Rasbian Jessie worked. Before I tried to upgrade Wheezy to Jessie and I don't think it worked out very well.
    – dlweb
    Aug 16, 2016 at 23:17

4 Answers 4

3

dlweb, is this the menu item you're missing?

Raspberry Pi Configuration Menu

It's been around since the release of Raspbian Jessie, so since 2015.

The Preferences → Raspberry Pi Configuration menu runs a subset of the options available through raspi-config, so you should be able to configure the system by opening a terminal and issuing this command:

sudo raspi-config

Editing config.txt or using rpi-update are really only for fixing very specific problems, and most users shouldn't need to resort to those levels.

1
  • It looks very similar, but it does not offer the Raspberry Pi Configuration, Add/Remove Software and a few of the other menu items that you are showing. I realize the config.txt is not the place I need to be. I have looked through and understand how 'sudo raspi-config' works.
    – dlweb
    Aug 15, 2016 at 20:09
2

To reinstall the gui version of the raspi-config use this command :

sudo apt-get install rc-gui

1
  • This is the actual answer, when you install "lite" this is missing.
    – Guillochon
    Dec 5, 2017 at 19:00
0

If you really want to be able to launch it from the GUI, see if it's in the main menu editor under "preferences". If so, add it and click "apply". Then, it should show up in the menu.

2
  • I'm sorry if my answer isn't very specific. Nov 16, 2016 at 21:00
  • Hi. I accidentally removed the raspberry pi configuration. When I click on main menu editor to add it back but raspberry pi configuration is not listed there. How can I add it back. Thanks
    – S Andrew
    Aug 25, 2017 at 9:50
0

Okey, so here what worked for me

I could not open GUI Raspberry Configuration neither Recomended Software.

I used apt-get install rc-gui, which helped with Pi Configuration, but not with Recmonded Software. After comparing lunch command in properties i noticed there was a difference before and after apt-get

sudo-A rc_gui ---> sudo AE rc_gui

So i added "E" as well to sudo - A rp-prefapps and it worked

Maybe just adding this "E" will resolve problem without installing new rc_gui

1
  • Could you be more precise? The first sudo command is missing a space, the second is missing the dash. And that is option E, why would it help?
    – RalfFriedl
    Dec 18, 2019 at 7:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.