0

using RPi 2 headless with DAC audio, on NAD ampli

last week, after boot problem, format and install again Raspbian.

since i can't get sound from web radio, like this fipradioplayer

i get sound from youtube on web browser, but not from this web radio i get sound from mp3 on VLC too.

any help please ?

this RPi is only for this use, with browser run at boot with the link of the radio, for music at home.

web browser is epiphany or firefox ( for test but didn't work too)

thanks from France.

Pat

edit after pulseaudio install and pavucontrol

error to connect

edit 2 : test pulseaudio -v pulseaudio -v

1

You may have a problem that's unrelated to the fact that you're using a DAC, but with the radio webpage itself. This may be an easily fixable issue, however, I will offer a different approach:

After inspecting the webpage source, I noticed that the radio stream it plays is at th following URL: http://audio.scdn.arkena.com/11016/fip-midfi128.mp3. You can play this stream from VLC, mpv or whatever desktop player you like, and it should be much more stable and less resource-heavy than the web-based player.

| improve this answer | |
  • thanks a lot, i'll try this on VLC, but what do you mean about :This may be an easily fixable issue, – pat Aug 16 '16 at 8:10
  • Are you using PulseAudio? If so, could you please run pavucontrol and see if an audio stream appears when you open the webpage in firefox? The stream is usually called "CubebUtils". If it doesn't appear, it means that firefox doesn't even open the audio stream, and the problem is webpage-related. If it does appear, you could see if it is piped into the correct device, and if it isn't muted. – dexterlb Aug 16 '16 at 8:21
  • i use alsa config, don't know about pulseaudio. thanks again, i'll check that at home and reply here – pat Aug 16 '16 at 9:27
  • Pulseaudio is an audio layer which acts above ALSA. You can read about it in the debian wiki. I think firefox (and other browsers) require pulseaudio to play sound, or at least their non-pulseaudio library support is buggy. – dexterlb Aug 16 '16 at 9:37
  • is pavucontrol installed with pulseaudio ? i've just to do apt-get install pulseaudio to get both ? neewbie style :) – pat Aug 16 '16 at 13:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.