0

I've been playing around for over a week now, and I have had no luck whatsoever in getting any operating system to boot onto my Pi Zero. I started by flashing an image of RetroPie, but that gave me different results every time I powered on. The most consistent error I got was that it hung at a start job attempting to set up console font and keymap. When it isn't doing that it tends to get so far into the boot process and then cascade into garbled text and then shows a pile of random characters while the light stops blinking and the keyboard won't respond.

I've now tried multiple new SD cards, two different keyboards, a selection of power supplies, and multiple operating systems. I attempted to just get Noobs or Raspbian going, but they have similar issues. I ordered a new micro-usb port adapter in hopes that maybe it's causing my problems, but it seems thin.

Any ideas? Is it possible I did something to break my Zero? There seems to be a lot of null pointer errors in the garbled text, is this a RAM thing?

RetroPie image: https://github.com/RetroPie/RetroPie-Setup/releases/download/3.8.1/retropie-v3.8.1-rpi1_zero.img.gz

EDIT: I did get Raspbian to boot once all the way to the config screen, but after a reboot command it re-started and then crashed to garbled text. Success seemed like a fluke in this case.

  • 1
    Can you edit your question to include a link to the RetroPie image you're using, and the amperage of the highest current power supply you've tried? As you're having problems with multiple OS images, I'm inclined towards thinking that your power supplies just aren't supplying enough current. – goobering Aug 16 '16 at 13:47
  • Sure, the image I'm using is this one: github.com/RetroPie/RetroPie-Setup/releases/download/3.8.1/… which should work for the Zero – John Rusch Aug 16 '16 at 14:31
  • The power supply is this one, which I thought was appropriate. smile.amazon.com/gp/product/B01D8VL8NA/… I'm not sure what my other one is, it's a LG fast-charge block with the matching cable. – John Rusch Aug 16 '16 at 14:34
  • 1
    Have you tried Raspbian with no keyboard at all connected and just a display? This means you could also ditch the use of an OTG hub. The display will still show the boot process. Unfortunately then plugging in a hub and keyboard may reset the power, but it will at least rule them out as culprits if the boot makes it to login/raspi-config first. – goldilocks Aug 16 '16 at 15:02
  • 1
    I don't think goobering meant as in normal heat, he meant as in heat due to a defect. If there's no enclosure that should be easy to detect. Touch the processor with your finger. It should be warm, not hot. If it gets quite warm (50 C/ 120F), it may be busy looping due to a problem, but that's not a hardware issue. If it gets uncomfortable to touch, that's a very bad sign :( WRT to trying it without any USB hub attached, do, using a freshly installed image. BTW, you are using an OTG hub right -- not a regular USB hub? – goldilocks Aug 16 '16 at 15:29
1

I've found the issue. After swapping out components (power supply, keyboard, OTG adapter, and SD card) I broke down and purchased a new RPi Zero. Sure enough, after hooking up identical components to the new Pi, it fired up like a charm.

My suspicion is RAM issues, but I don't have solid evidence for that conclusion other than having null pointer errors referring to memory addresses during crash. I don't know enough about hardware to say for sure, I'm just glad to have resolution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.