0

I am trying to mount a folder from one Raspberry Pi to another one.

The Raspberry Pi I am trying to mount is running Ubuntu Mate and I have shared the folder and gave it guest access and write access.

The Pi which I am trying to add the mount to is running Raspbian.

So far I have tried to mount the drive by using:

sudo mount -t cifs //10.177.43.200/home/administrator/Test /media/NetworkDrive -o username=user,password=pass

and by editing the fstab and adding:

//10.177.43.200/home/administrator/Test /media/NetworkDrive cifs guest,uid=1000,iocharset=utf8 0 0

but both results give me the same error:

Retrying with upper case share name
mount error(6): No such device or address
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Any help is greatly appreciated, thanks everyone!

1
  • Also for those wondering I can successfully ping the host server and all the user names and passwords match the computer Aug 16 '16 at 13:53
0

Well it seems that after working all day on this I have finally figured it out.

On my Raspberry Pi that i was using as the server (the one running Ubuntu Mate) I told it which folder I wanted to share.

In my edits to the fstab I had the server location as //10.177.43.200/home/administrator/Test, however since i already declared which folder i wanted to share all I had to do was point to the shared folder which was previously declared.

So the corrected fstab should be as follows:

//10.177.43.200/Test /media/NetworkDrive cifs guest,uid=1000,iocharset=utf8 0 0

Also this was just to test if i could mount my drive successfully so if you are to use this in a real application I highly recommend you use a credentials file

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.