During a strong file I/O application, the Pi regular crashes.

mmc0: Timeout waiting for hardware interrupt - cmd25.
mmc0: Timeout waiting for hardware interrupt - cmd12.
mmc0: Timeout waiting for hardware interrupt - cmd13.
mmcblk0: error -110 sending status command, retrying


Message from syslogd@pippin at Mar 8 19:03:21 ...
 kernel:[  735.850687] journal commit I/O error


[  1301.251534] journal commit I/O error

using Raspbian "wheezy" 2013-02-09-wheezy-raspbian.zip (and updated)

Different Raspberry Pis and different SD-Cards (same series) cause the same problem. I test other cards in a few days. I remember a different card (class 6 instead 10) would have held out for a week already.

memtest 480 2 is okay Measured Voltage on TP1 and TP2: 4.87V Tried with and without USB-Hub with a power supply.

Is there a way to tell the watchdog, the system (mmc0) crashed?

A dirty hourly cron execute /sbin/init 6 does not work in this case. Reverse ssh neither.

I know I am not alone with this problem: http://elinux.org/RPi_SD_cards But I can't test hundred cards.

I want to play it safe and fix it automatically if need (restart is a acceptable solution for me).

By the way: Restart the Pi every hour just delay the problem. Sometimes it occurs after 2 minutes.

Thank you for any help. Kind regards from Berlin

2 Answers 2


I was getting these errors on bootup - however not during normal operation. My problem was resolved when I switched from a TV (using HDMI cable) to a monitor (using HDMI to DVI cable). And also when I swapped to a different keyboard. If I unplugged the original keyboard before bootup ( to Raspbian GUI), and then plugged keyboard in after bootup, I would not have the issue. So I personally think the problem in my case related to excessive current draw on RPi. And from what you have explained - I think it might be the same in your case.

My original keyboard was one of those flexible rollup keyboards. I swapped to a simple no-frills keyboard - (and to monitor) and issue resolved.

Not sure if this helps you, but hopefully will help others.

  • Until the appearance of the error no monitor and no Tastur was connected. I no longer have the Raspberry Pi. Changed to Zotac Barebones. Thanks anyway Commented Apr 6, 2014 at 22:24

I don't know exactly what's the matter behind the issue, but I got same error that caused a stucked system on arch linux running on a raspberry pi 2 as soon as i had updated to linux kernel 4.1.9-1-armv7h.

To solve, I just did a downgrade to 4.1.6-2-armv7h and the issue disappeared.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.