0

Help!

I got a raspberry pi for my son and he has managed to set the font size on the desktop to the largest value as he thought it funny. Unfortunately I can't see how to set them back to normal so its hard to do very much.

I tried the appearance menu but can't see font size or its below where I can get to. The large fonts mean not all the menu items fit on the screen.

Am thinking of re-flashing but wondered if there was a setting I could change using the console (this is the only thing with normal fonts!).

| improve this question | | | | |
  • "he thought it funny" -> I hate to agree...if it helps, the default desktop environment (DE) used on Raspbian is LXDE, which has been around for about 10 years; you'll notice they have their own forum and documentation linked there. I've never really used it so I don't have any specific suggestions myself. – goldilocks Aug 16 '16 at 17:01
1

Take a look at this post. In this user's case, the font settings are stored in: /home/user/.config/pcmanfm/LXDE/pcmanfm.conf I haven't verified this on Raspbian, but poking around the .config folder might reveal a relevant file of sub-folder.

Open a Terminal (CTRL-ALT-T should work, if you can't find a shortcut), then navigate the folders using the cd command. Terminal should open with you already located at /home/<username>, so just type cd .config and hit enter. ls will list files in the current folder, you may need to use cd a few more times. In the example above, you would have to cd pcmanfm then cd LXDE, and then ls should show you the files, look for a relevant one (pcmanfm.conf in the example above).

Once you've found a file you want to look at or edit, you have a few options. The world is divided into two factions: those who like nano, and those who like vi. Type nano <filename> and hit enter, if it says it's not installed, type vi <filename> hit enter and hold your breath.

Nano is the easier one to use, but if you must use vi, scroll up and down using the arrow keys, when you want to type something, hit i first (to switch to "insert mode"), then type. Try not to use backspace, delete or the arrow keys while in insert mode, some keyboards will screw up your text file. If you must, hit ESC to return to "non-insert mode," and hit i again when you are ready to type. When you are done, hit ESC, then type (it will appear at the very bottom of the screen) :x (this will save and close). If you bugger something up and want to quit without saving, hit ESC and type :q!.

| improve this answer | | | | |
0

If you have a NOOBS sd card then go back to appearance settings. Go to system hit the box on the right of font then click size and change the size. Done!

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.