0

I need to download an operating system for my raspberry pi that works with pitft and I found two different version on PI's website - full version and Lite-based. So, what is Lite-based OS as supposed to Full version... First instance, here is the link for the download page. It says Download Jessie and Download Lite-Jessie...

https://learn.adafruit.com/adafruit-pitft-3-dot-5-touch-screen-for-raspberry-pi/easy-install

So, I need to know if they are the same and it will work with my 3.5 pitft display.

4
  • Either should work, but you'll generally have an easier time with 'full' Raspbian, rather than 'lite' Raspbian. The Lite version is the same as the full version, but with a whole bunch of stuff left uninstalled to reduce its size. Until you're sure that you don't need the extra stuff, it's easier to install the full version.
    – goobering
    Aug 16, 2016 at 17:12
  • original close reason incorrect, as the "already has an answer" isn't about pitft
    – scruss
    Sep 26, 2017 at 19:31
  • @scruss: It doesn't need to be specifically about pitfit. As the answers over their explain, it's the same operating system, just with different packages installed.
    – Jacobm001
    Sep 27, 2017 at 15:17
  • @Jacobm001 the OP asked “I need to download an operating system for my raspberry pi that works with pitft”. Full PiTFT support is dependent on Adafruit's custom kernel overlays. At the time of this comment, PiTFT is not supported on current Raspbian (Stretch) of any flavour. So pointing to a generic “Lite/Full” difference answer is incorrect. (Disclosure: I work for an Adafruit reseller, and we see this issue a lot.)
    – scruss
    Sep 27, 2017 at 17:40

1 Answer 1

1

The images that adafruit are supplying are images where the TFT screen driver had been installed... (So basically, adafruit have run the DIY Installer script and they're distributing the installed version)

The lite version of Debian Jessie is a cut down version with less features, it is much more lightweight, but its features have been cut down

I suggest you use the DIY Installer...

Not the answer you're looking for? Browse other questions tagged or ask your own question.