0

I have spent hours reading articles and changing file after file over and over again. I am truing to properly set up my Edimax ew-7811un wifi adapter on m a Pi Zero running Kali Linux. I was able to set it up once upon a time when I had Jessie running on it. I remember that it was a pain setting it up back then and it's even worse now. I believe that I possibly used a bach file to set things up in the end.

My current situation is simple. My Pi sees the adapter, it even flashes blue. I've changed the /etc/network/interfaces and the /etc/wpa_supplicant/wpa_supplicant.conf (had to create it because it did not exist) multiple times. The network logo appears to be connected, but it does not connect to my network.

auto wlan0
iface wlan0 inet dhcp
wpa-ssid"NAME"
wpa-psk "NETWORK_PASSWORD"

I updated the Interfaces File multiple times and this is the latest rendition. I saw that many people resolved their issue by directly placing their network info into the interfaces file. I still ran into the same issue.

ctrl_interface=/var/run/wpa_supplicant ctrl_interface_group=0 ap_scan=2
network={
        ssid="NAME"
        scan_ssid=1
        proto=RSN
        key_mgmt=WPA-PSK
        pairwise=CCMP
        group=CCMP
        psk="PASSWORD"
}

This is what the wpa_supplicant file looks like as of now. Even though it isn't being called it still exists as a file.

The adapter currently doesn't seem to work because of the changed interfaces file, but when it did "work" it wouldn't receive an IP address. I would have to run sudo ifdown wlan0 && ifup wlan0 to enable it and get it to start blinking. It would also show that it was connected to my router but it would not connect to the internet.

There is not a single article that is specific to my issue (TBH, no article is always specific to one issue) but I really need to figure this out. I can never master something if i'm always getting stuck in the process. I don't like asking for help, but help. I'll provide as much information as possible. There are a lot of factors that go into this. Thanks in advance.

UPDATE

After applying the changes that @Jason Woodruff I got the following:

spa_supplicant: /sbin/spa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Failed to bring up wlan0

UPDATE_4

Update_5 SOLUTION

Following Update 3 of the answer helped to solve my problem. Ensure that the hub is getting enough power and is able to scan for available wifi hotspots.

After confirming the connection on root and user profile you can then run sudo apt- update and sudo apt-get upgrade

After performing the upgrade and rebooting, you will get most if not all of the Kali tools.

  • Can you edit your question and add a full listing of both your network/interfaces and wpa_supplicant.conf files? Also, it would be worth ruling out other issues - can the adapter connect to other networks? Have you tried, for example, connecting to a mobile phone hotspot? – goobering Aug 20 '16 at 9:56
  • @goobering I updated the question. Hope that helps. – Pepe Aug 21 '16 at 18:54
  • It might sound stupid but have you got MAC filtering enabled in your Router? I.e. even with a password it will deny access to WiFi devices that are not on its "approved" list - in this day and age it is not unreasonable to be a bit paranoid what devices you allow to connect to your Broadband (to prevent WarDriving)... – SlySven Aug 23 '16 at 18:33
0

From what I read on the Kali forums, it's ARM version ships with an outdated driver for the Edimax EW-7811Un. Just for knowing, run this command:

lsmod

To see if you see something like:

8192cu

I'm just going out on a limb here, I think your dealing with an outdated driver for that wifi dongle. I believe you'll find more help over at the forums

UPDATE:

If you will, try this:

Make the section for your wlan0 in /etc/network/interfaces look like this:

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

In your wpa_supplicant.conf file, make it like this:

country=US
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
               ssid="YOUR_SSID"
               psk="YOUR_PSK"
}

Good luck

Update 2:

Backup your current interfaces file

sudo cp /etc/network/interfaces /etc/network/interfaces_old

Now make a new file:

sudo nano /etc/network/interfaces

Copy and paste this in there:

# interfaces(5) file used by ifup(8)  and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/ dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/   interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet manual

allow-hotplug wlan0
iface wlan0 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

Change your ssid back, as it is actually spell. If there is uppercase letters in it, use the same. That goes for your password too. In your wpa_supplicant.conf file.

Reboot and test.

UPDATE 3:

We'll Pepe, I got my Edimax connected. It happened as root (only) and I only had to use the /etc/network/interfaces file. No wpa_supplicant.conf file.

Here is my file:

 auto lo
 iface lo inet loopback

 auto eth0
 iface eth0 inet dhcp

 auto wlan0
 iface wlan0 inet dhcp
 wpa-ssid "my_router"
 wpa-psk "my_password"

It takes about a full two minutes to connect, but it does connect. Some kind of script runs that slows things down. I hope this helps. Other than mine being a RPi B, not zero, we have basically the same setup. The only thing I can think that could be hindering the connection is your router's encryption type. Epecially if it's an ols WEP kind.

Good Luck!

Update 4:

Add your username to the "sudo" group. To do that type this as root:

adduser pepe sudo

Make this part of the instructions.

  • When running lsmod, 8192cu does pop up. I believe my problem comes from the interfaces or wpa_supplicant.conf files. It seems that every article has a different way of writing the interfaces and wpa_supplicant files. I just need to know the write way of writing them for Kali on the Pi Zero. – Pepe Aug 21 '16 at 16:33
  • I updated my answer. – Jason Woodruff Aug 21 '16 at 19:23
  • Unfortunately, that did not seem to work. I updated my question to include what happened after replacing the text in the files. – Pepe Aug 22 '16 at 1:41
  • What is the output of this command: tail -n300 /var/log/syslog | grep wlan0 – Jason Woodruff Aug 22 '16 at 3:01
  • Also, you do have a password for your router? – Jason Woodruff Aug 22 '16 at 3:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.