2

I have wrote a c++ program to display camera picture using opencv command imshow, worked perfectly on Wheezy. Lately I've updated my RPI to latest Jessie. Now I get the GdkGLExt error when running my program through a VNC client (direct connection doesn't have any problem).

On the raspberry forum suggested to installing libgl1-mesa-swx11 and it worked, but when compiling get the following errors:

usr/bin/ld: cannot find -lGL
usr/bin/ld: cannot find -lGLU

Elsewhere suggested to installing libgl1-mesa-dev and libglu1-mesa-devto resolve above errors, but installing these makes removing libgl1-mesa-swx11.

Any help appreciated (except downgrading to Wheezy:)).

0
2

Despite the fact that direct connecting to RPI (hdmi interface) instead of tightvnc has no problem I came up using x11vnc and it worked like a charm. With x11vnc you have connecting to the main display interface, read further information and configuration in Code Chief's Space.

Note: if you have problem with your keyboard (like me) and your keyboard doesn't repeat when you hold a key then add -repeat argument to the x11vnc start-up file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.