0

I bought myself TP-WN823N WiFi dongle for my Pi Zero. I can't connect with WiFi. I looked with lsusb and found that it isn't connected as USB device.

I have USB hub (non-powered) where I have keyboard and mouse and that WiFi dongle. I have also tried to connect that WiFi tongle alone but still no activity light.

Is it possible that Pi Zero doesn't support that WiFi dongle?

I am using Raspbian 4.4.11+ and powering with 1A. I think the power isn't limit cause I use 0.5A with keyboard and mouse.

1

The dongle is supported. You can't find the dongle via lsusb, this means the dongle isn't not connected. You have a non-powered usb hub with a keyboard and mouse, this seems like the problem. Even if the dongle is getting .5A, that may not be enough. Note, this can also be a problem of the hub, the hub can also be drawing more power than expected. This is a simple thing to verify, just unplug the hub and connect the wifi adapter directly to the board and see if it's detected (you can use a bash loop to keep running lsusb).

0

First connect raspberry pi zero to internet via usb cable to your phone in tethering mode. Update and upgrade distro

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.