1

I got this new raspberry pi 3 B with an 8GB sd with the necessary OS options. I tried the following:

  1. HDMI I tried connecting the hdmi cable from pi to my laptop which has linuxmint 17.03 Rosa installed in it. Generally Fn + F8 button should have swapped the video output for the laptop with the raspberry pi out but it's not working.

  2. SSH

My linuxmint has a ssh client. So it should have been able to connect to pi. I get a message Connection refused on port 22.As I understand, changing the port to some other port number should do the trick but I am not sure if raspberry pi has the ssh open.

I am using ssh . I received the ip address from the router.

It is supposed to be simple to get it working. I am sure I am doing it wrong somewhere? What could be the simplest solution to this ?

  • 1
    The HDMI port on your laptop is an output not an input. How is your Pi connected to the network and what SSH command are you using to connect? Note: add these answers to your question not the comments. – Steve Robillard Aug 25 '16 at 23:40
  • @SteveRobillard I have updated the question – freerunner Aug 25 '16 at 23:56
  • Yes, but you only answered half of what I asked. Cherry picking what you want to answer is not going to net much progress. What OS and version are you using on the Pi and do you have a monitor or TV that accepts HDMI and a keyboard and mouse. It would make getting the initial setup done easier. – Steve Robillard Aug 26 '16 at 0:08
  • Yes I have keyboard /mouse but no tv, just laptop for video output. I dunno about the os since this is a brand new purchase and I have not been able to select the os from the usb I received. I am very new to using pi so pardon if I didnt answer correctly. – freerunner Aug 26 '16 at 0:26
  • usually, you need to run through setting up your pi using keyboard/mouse/monitor if you want to enable SSHD (I don't think it's enabled by default) - once sshd is enabled on the pi, you should be golden using your ssh client – Jaromanda X Aug 26 '16 at 1:43
4

You're trying to connect two outputs to each other, which won't work.

If your Pi is running Raspbian then SSH should be up and running by default.

Two things could be stopping you from connecting:

  1. Your Pi's operating system didn't start up properly, and without a screen you can't see what it's doing.
  2. You're connected wirelessly, and your wireless router has the "wireless isolation" setting enabled. This setting prevents wireless clients from communicating with each other.

I suspect what's happened here is you've inserted the NOOBS SD card into your new Pi and switched in on. What you can't see is the NOOBS first run menu which is asking you which operating system you want to install.

I recommend that you download the latest Raspbian image without the NOOBS installer and boot from it directly.

  • Hi Aaron. I also suspected this would be due to the noobs menu. I followed your suggestion and installed bootable raspbian in microsd but now the ethernet is not working in the pi. I put the sd card to the pi and boot it, but all the ethernet lights are gone now! I used the latest version of raspbian! – freerunner Aug 26 '16 at 19:43
  • This sounds like the OS isn't booting or that the network cable could be faulty. There's a green LED next to the red power LED which should light up when the SD card is accessed. Does it flicker for about 20 seconds after you turn it on? If it doesn't, then the OS isn't booting and you should try writing the image again (or try the testing version of Raspbian, or another distribution like Ubuntu MATE) – Aaron F Aug 27 '16 at 16:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.