0

For some reason, my WIFI dongle doesn't want to connect to the internet anymore. It was not too long ago. But I think something happened that caused it not to work. I can't figure out what's going wrong but I think it has something to do with me uninstalling the dhcpcd5 package.

I have a strong feeling that removing that package somehow messed up my WIFI connection. It was working perfectly before that. If anybody knows what to do about this, that'd be great.

I even tried to connect to my pi through an ethernet connection but I still have no luck with it. I can't even scan it on my network.

I know for a fact that the WIFI was configured correctly because everything seemed to work fine until not too long ago. I have absolutely no clue what I did. Let me know if you need anymore information than this.

Thanks for any help. It's appreciated.

  • What is the output of ifconfig? What is the output off lsusb? Have you tried reinstalling dhcpd5? – Steve Robillard Aug 26 '16 at 6:05
  • @SteveRobillard Everything's fine. I need to reinstall dhcpd5 but I can't figure out how to do it without a network connection. – Zachary Vincze Aug 26 '16 at 6:06
  • First everything is not fine or you would not have asked a question? The things I asked for will help us diagnose the problem something you admitted several times in your question that you don't know. To install a package (assuming you are using Raspbian) do the following sudo apt-get install dhacpd5. – Steve Robillard Aug 26 '16 at 6:10
  • This is one of these 'I cut my hand off with a chainsaw and now it doesn't work' questions. WHY did you delete your network management software???? Do you have a backup? We MAY be able to suggest a fix if you list the contents of your /etc/network/interfaces and /etc/wpa_supplicant/wpa_supplicant.conf files. – Milliways Aug 26 '16 at 6:16
  • 1
    @Milliways I do, I just wanted to know if there was a better way. Offline package installation maybe? – Zachary Vincze Aug 26 '16 at 6:18
0

Well, I've fixed it by restoring from another backup I had. I don't even know if I should keep this question up. But just in case there are people out there who are as clueless as I am.

DO NOT DELETE THE dhcpcd5 PACKAGE EVER

Never thought I'd be saying that. Nobody in their right mind would delete their network management software, right? I learned the hard way. Took a lot of work getting the computer back to normal.

Fortunately, there is a much better solution for other people that may run into this problem.

Here's how you can install the package without a connection.

  1. Download the dhcpcd5 package here.
  2. Move the .deb package onto a usb drive.
  3. Plug that drive into one of the PI's usb slots.
  4. To mount the drive, use this command sudo mount /dev/sda1 /path/to/mount/folder. sda number will vary.
  5. Move the .deb file into your home folder.
  6. To install the package use the command sudo dpkg -i /path/to/deb/file followed by the command sudo apt-get install -f.
  7. Restart the Pi. Hopefully, your internet connection will be working once again. If it doesn't work, there may be another problem.

If anyone needs more information on how to get this done. Leave a comment and I'll try to get back to you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.