1

I already tried How do I set up networking/WiFi/Static IP but without success.

The IP address I would like to assign the pi would be 10.0.0.5. This worked well and at the time I am connected to it via SSH. But unfortunately I can not resolve any hostnames.

E.g. ping www.google.com results in unknown host but ping 8.8.8.8 works. I also cannot get any packages which is obvious because it cannot resolve the hostnames.

Below is my current /etc/network/interfaces file. The address, netmask and gateway are correct. I also disabled dhcpcd and enabled networking as mentioned in Network Interfaces method at the linked answer. I also tried the dhcpcd method but it is not working either. I am running Raspbian Jessie on it.

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
    address 10.0.0.5
    netmask 255.255.255.0
    gateway 10.0.0.138

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

I cannot find a way to get it working and I am hoping someone could help me to be able to resolve the hostnames again

  • You don't appear to have defined any dns servers – Steve Robillard Aug 26 '16 at 8:30
  • I had it in the config but it doesn't also if it is defined. Also Milliways said that it wouldn't be necessary to define one – Nico T Aug 26 '16 at 8:33
  • 1
    You probably HAVEN"T followed the tutorial (which still is sub-optimal). List the values you obtained in "Find the Settings of your local Network" – Milliways Aug 26 '16 at 8:33
  • 2
    No I said "this is generally not necessary", because this is often the same as gateway. Your gateway looks unusual. Also if you want to manually set IP you really need to understand what the settings mean. – Milliways Aug 26 '16 at 8:36
  • You probably don't need a static IP either. – Steve Robillard Aug 26 '16 at 8:37
4

You have not defined a DNS-server. You have to manually define that when you are setting a static IP in the /etc/network/interfaces file. If you instead have used to router (or DHCP-server) to assign an IP-address, defining a DNS-server would not be necessary.

Change the following lines:

auto eth0
iface eth0 inet static
address 10.0.0.5
netmask 255.255.255.0
gateway 10.0.0.138

to

auto eth0
iface eth0 inet static
address 10.0.0.5
netmask 255.255.255.0
gateway 10.0.0.138
dns-nameservers 8.8.8.8 8.8.4.4

where 8.8.8.8 and 8.8.4.4 is the DNS servers (in this case it is googles primary and secondary DNS)

0

see this video for how to fix wifi instance on Rasbian Jessie 1.3.6 and OctoPi 0.14.0

https://www.youtube.com/watch?v=dZeJb6Jv-9E

From Wheezy to Jessie they changed the way that the wifi instance connects to router using a static ip address... (or something, Im not a developer...)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.