1

I have been following some excellent tutorials on How to Install Jenkins onto a Raspberry Pi.

After changing the Raspberry Pi 3 Model B's default Java version to 1.8.0_101 and completing the steps to add the updated debian key to apt-get, I am failing at the point of sudo apt-get install jenkins

pi@raspberrypi:~$ sudo apt-get update
Hit http://archive.raspberrypi.org jessie InRelease
Ign http://pkg.jenkins.io binary/ InRelease      
Hit http://pkg.jenkins.io binary/ Release.gpg     
Hit http://archive.raspberrypi.org jessie/main armhf Packages
Hit http://pkg.jenkins.io binary/ Release
Hit http://archive.raspberrypi.org jessie/ui armhf Packages    
Hit http://pkg.jenkins.io binary/ Packages                     
Ign http://archive.raspberrypi.org jessie/main Translation-en_GB
Ign http://archive.raspberrypi.org jessie/main Translation-en
Ign http://archive.raspberrypi.org jessie/ui Translation-en_GB
Ign http://archive.raspberrypi.org jessie/ui Translation-en
Ign http://pkg.jenkins.io binary/ Translation-en_GB
Ign http://pkg.jenkins.io binary/ Translation-en
Reading package lists... Done

pi@raspberrypi:~$ sudo apt-get install jenkins
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 jenkins : Depends: daemon but it is not installable
E: Unable to correct problems, you have held broken packages.

I have tried to find some information online about what this could be referring too, but have struggled to find anything concrete.

I ran the following:

dpkg -l | grep daemon

Which returns nothing similar. So I think I am a little stuck. Has anyone got any idea of a resolution or next step to try?

0

I tried to reproduce the scenario that you have mentioned while installing Jenkins. I have a java version of 1.8.0_65-b17.

However I feel this is something to do with the version of distro. I am using noobs 1.9.2 and the firmware is 4.4.3+ and the version is VERSION="8 (jessie)".

sudo apt-get dist-upgrade
sudo apt-get update
sudo apt-get install jenkins

Hope it would resolve your issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.