I started running my Raspberry Pi with a monitor and keyboard, but I ended up decapitating it and don't need the GUI running anymore. How do I make it not start at boot?

  • What OS are you running? Assuming you are running a recent version of Raspbian you can run sudo raspi-config and select boot options from the menu and then console. – Steve Robillard Aug 27 '16 at 0:42
  • @SteveRobillard Thanks. Will the GUI still run in the background though? – Sith Siri Aug 27 '16 at 0:43
  • No, you have to manually start it with startx, you can verify that by running the followinf ps aux it will show all the running processes no matter who owns the process – Steve Robillard Aug 27 '16 at 2:15

As suggested by steve use raspi-config for setting up the GUI.

Steps 1. on the prompt type

sudo raspi-config
  1. Step 2 Select the option highlighted "Boot Option"

enter image description here

  1. Step 3 Based on your need select "Option B1/ Option B2".

enter image description here

  1. Step 4 - Click on finish and the prompt will ask for system Reboot. The system will boot to console from now on.

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.