1

I have been using the pi for almost a week now, I managed to set up the ssh connection and I have been messing around with it for a while now, it just works perfectly from my laptop (running ubuntu) using the "ssh pi@local ip from the raspberry" to the pi when I am at home, but I am unable to succesfully forward the ports on my router in order to acces the pi on networks outside my home one...

The thing is that I suspect my router is blocked in order to stop such attempts like changing the configuration in order to forward the raspberry port 22 so I would be able to use the "ssh pi@private ip from my home network" and connect to the raspberry from external networks, I can't seem to apply the changes on the router configuration page (gives me errors everytime I try to apply the forward) and it does not show any specific port forwarding tabs, thought it could actually be that I just dont know how to set up said forward.

My question might be more like a cluster of questions I guess, but, is there any alternate way to connect to the pi from external networks besides the one i plan on using? (i don't really want to give up on setting it so I could just use the afforementioned way of "ssh pi@private ip from my home network" so I guess this woul be my last shot.)

Could it be just that the router is blocked by my ISP? (using a comtrend router with its own firmware) I manly ask this one since I have been trying to do the port forwarding following various internet tutorials like this one but I got nothing but the same error over and over again. Should I in that case consider changing my router or trying to upgrade the firmware in my router?

And, in case I was just doing it wrong all along, does anyone know a good guide on doing the port forwarding configuration in order to get the raspberry working in a similar setup? (I would like to think that wouldn't be the problem but I guess I can never discard that since I am pretty new in all this, and I have been doing nothing but learning during this week run with my pi (wich proved as very gratficating experience that I want to keep on.))

EDIT: the ISP I have contracted is Telefonica, spanish based ISP.

  • What is your isp ? In my case it's belgacom. And I had to activate my ports on the settings page (not my bbox/router). – David Mar 13 '13 at 11:18
  • spanish based Telefonica... should i contact them? – Percy Mar 13 '13 at 14:07
  • possible solution : dslreports.com/forum/remark,16212820 – David Mar 13 '13 at 16:17
  • running canyouseeme.org on port 22 got me the following message Error: I could not see your service on ip on port (22) Reason: No route to host Is it blocked by the firewall then? – Percy Mar 13 '13 at 22:17
  • I think yes, did you try to DMZ it. – David Mar 14 '13 at 9:20
2

You router might not respond to your ICMP ping requests, which is why you get your 'can't reach the host' error. I also when I was setting up SSH through my firewall to my Pi the router was swallowing the SSH packets for its self as the ISP has setup the router to accept SSH packets to manage the router. To get around this I set up in the port forwarding section in the router to forward from port 24(public) to the internal PIs IP on port 22, then when in your SSH program for example Putty I changed port 22 to port 24 and entered my public IP, after doing that everything worked fine. Hope this helps you or someone else out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.