5

I have installed Raspbian and have attached 2TB External Hard Disk via USB with ext4 partition. I am trying to use it as a NAS device. Also I am accessing Pi over SSH from LAN and also from Internet. When I am accessing over Internet it gets disconnected randomly, lights on the board keep on blinking. It is not shown in connected devices list on my router Netgear (wnr2000v3). I am not able to figure out what is going wrong.

First I had connected via Ethernet and I have also tried using WiFi card but the case is same.

  • 2
    Maybe a power issue? Is your hard drive also receiving its power from its own adapter or an expertnally powered usb-hub? Running low on power can result in some awkward behavior rather than shutting down the pi entirely. (As far as I know, the wired network connection is hardwired in as a usb device.) – René Wolferink Mar 14 '13 at 9:24
  • USB drive have its own external adapter power supply. – vedarthk Mar 14 '13 at 9:31
  • can you test your power suply ? (rpiblog.com/2012/11/testing-raspberry-pis-power-supply.html) – David Mar 14 '13 at 10:18
  • 1
    I may have solved the issue, as stated by @RenéWolferink it was a power issue, I was using 5v 700mA adapter rather it should be 5v 1200mA. – vedarthk May 12 '13 at 15:09
  • 1
    I had the same problem. I was using 5v 1000mA and it kept losing the connection. Switched to 5v 2100mA and all is well. – ow3n Nov 26 '13 at 21:54
2

To sum up the answers given in the comments section (and get rid of another unanswered question):

Network disconnects were traced back to power supply issues. So beware of power brown-outs.

  • 5v 700mA adapter -> solution: 5v 1200mA adapter
  • 5v 1000mA adapter -> solution: 5v 2100mA adapter

Edit to add:

Here are some measurements regarding the power consumption of the various models of the Pi:

4

I had the same issue, using a 700 mA power supply. Power reqirements depend on what peripherals are connected. This power supply page concludes that using a 1200mA power supply from a reputable retailer will provide ample power to run the Raspberry Pi.

  • 1
    Hello and welcome. Thank you for your input and hope to see you around. – Ghanima Dec 16 '15 at 9:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.