2

I am working on a RPI 3. Operating system is Archarm.

I tried a suggestion to add arm_control=0x200 in /boot/config.txt for my RPI 3. So, it was expected to run in Armv8 mode. However, after rebooting RPI, the system stuck almost immediately in the "Rainbowscreen".

You can imagine that I was not able to access /boot/config.txt to strip out the ARMv8 mode line.

To fix the problem I tried to mount the sd card in my computer. However there is no config.txt on the first partition!

Any ideas to access /boot/config.txt apart from a complete renstall of the operating system?

  • I am assuming your computer is a windows box. Have you tried a live CD. However, usually the boot partition is a FAT partition which you can read from a PC, Linux and even Mac IIRC. – Steve Robillard Sep 1 '16 at 19:52
  • My pc has ArchLinux as OS, not windows. I tried as root mount /dev/sdb1 /home/user/sd. Only showing directories "grub" "lost+found", "memtest86+" and "syslinux" and initram images. – kzpm Sep 1 '16 at 20:04
1

Simple solution: there was another partition /dev/sdb2 that contained /boot/config.txt. So I was able to remove the arm_control=0x200 line.

Flawless boot!

Solved!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.