1

I am having a recurring issue with my raspberry pi 3, I have my router (linksys E2500) setup with DHCP reservations for all my network devices. This raspberry pi has 192.168.1.34/26 and gets this ip address, but when rebooted it receives the 192.168.1.34/26 and 192.168.1.36/24? I have deleted the.36/24 address repeatedly and every reboot it comes back. Output from "ip addr show eth0"

2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether b8:27:eb:de:9e:cb brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.36/24 brd 192.168.1.255 scope global eth0 
       valid_lft forever preferred_lft forever
    inet 192.168.1.34/26 brd 192.168.1.63 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::ba27:ebff:fede:9ecb/64 scope link 
       valid_lft forever preferred_lft forever

It has been impossible to search this and find any information other than the typical static ip "tutorials" or ref to etc/network/interfaces vs dhcpcd.conf...both of these files are default in this case. This raspberry pi is setup to run my plexmediaserver and run headless. Thank you for looking

Edit as requested

pi@plex-ht:~ $ cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet manual

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

Output of etc/dhcpcd.conf

pi@plex-ht:~ $ cat /etc/dhcpcd.conf
# A sample configuration for dhcpcd.
# See dhcpcd.conf(5) for details.

# Allow users of this group to interact with dhcpcd via the control socket.
#controlgroup wheel

# Inform the DHCP server of our hostname for DDNS.
hostname

# Use the hardware address of the interface for the Client ID.
clientid
# or
# Use the same DUID + IAID as set in DHCPv6 for DHCPv4 ClientID as per RFC4361.
#duid
 Persist interface configuration when dhcpcd exits.
persistent

# Rapid commit support.
# Safe to enable by default because it requires the equivalent option set
# on the server to actually work.
option rapid_commit

# A list of options to request from the DHCP server.
option domain_name_servers, domain_name, domain_search, host_name
 option classless_static_routes
# Most distributions have NTP support.
option ntp_servers
# Respect the network MTU.
# Some interface drivers reset when changing the MTU so disabled by default.
#option interface_mtu

# A ServerID is required by RFC2131.
require dhcp_server_identifier

# Generate Stable Private IPv6 Addresses instead of hardware based ones
slaac private

# A hook script is provided to lookup the hostname if not set by the DHCP
# server, but it should not be run by default.
nohook lookup-hostname
  • You say etc/network/interfaces is default, but do not list it. This looks like 2 mechanisms are attempting to resolve. – Milliways Sep 3 '16 at 2:09
  • For now I have rigged it to delete the rogue ip address @reboot in crontab. This is working fine, but the OCD AR part of me knows it's still an issue. What I plan to do next is use a spare SD and bare install of jessie to see if it's something in my config or specific to the pi/eth0. I'll post back results. – Eric Lewis Sep 4 '16 at 15:04
0

BLUF:only add the ip address for your pi to /boot/cmdline.txt if you can remember to update when you want to re-ip your network...

I started reviewing the steps I took to setup plex media server on the raspberry pi 3, and there it was at the very end of the line in /boot/cmdline.txt

dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait ip=192.168.1.36

Above all else, document, document, document, this pi had historically pulled the .36, but to conform to my desires I made it .34 to align with my ip scheme. Thanks all for looking and those that offered assistance. Hopefully this will be a lesson for others.

  • And the lesson is DO NOT USE A STATIC ADDRESS and if you do DON"T PUT IN /boot/cmdline.txt – Milliways Sep 5 '16 at 0:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.