1

On my RPi 3, whenever I try to change songs with MPD, it hangs such that it's only killable with -9. I'm using the default sound setup and mpd.conf, and the built in 3.5mm jack. I've upgraded to the latest firmware. There is no log output when you try to change songs, as it hangs before it can print anything. How can I get this working? Note that after a kill9 and restart, it will play the current song.

2 Answers 2

3

I had the same problem on my Pi3B but could fix it by uncommenting "device" option in the "audio_output" block (in my case ALSA) in mpd.conf.

0

Disable "alsa" output in mpd.conf Use "pulse" output instead.

Also, if you hear choppy noise, add the following change in /etc/pulse/default.pa

load-module module-udev-detect **tsched=0**
1
  • Pulse does the same thing. Next chance I get I'll try that command Sep 14, 2016 at 5:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.