0

I setup a static IP on my Pi using "/boot/cmdline.txt" (I run it headless most of the time) But when i try booting it up with a monitor, mouse and keyboard it goes into the cli before booting(as usual) but then it shows:
"waiting 110 seconds more for network"
"waiting 100 seconds more for network"
"waiting 90 seconds more for network"
...

To stop it i had to remove the ip=xxx.xxx.xxx.xxx in "boot/cmdline.txt" But i want to set a static ip, How do i do it without getting the above error...

On further browsing i found this: https://www.youtube.com/watch?v=5DCPDQnRXm8 please tell me if it is fine to do this

Pls help
Thanks to anyone who tries to help me...

3
  • I assume you are running Raspbian. This runs dhcpcd by default. The old method of setting an IP in cmdline.txt may still work, but Raspbian is really designed to work out of the box with a normal network. Static IP addresses are a bad idea, but if you are determined to use one anyway see How do I set up networking/WiFi/Static IP – Milliways Sep 3 '16 at 10:05
  • @Milliways: why do you say using static IP addresses is a bad idea? There are many use-cases for this: being able to connect reliably remotely, being able to assign it a DNS name etc. – stevieb Sep 3 '16 at 15:34
  • Have you tried sudo raspi-config, disabling Wait for Network at Boot? – Kong Chun Ho Sep 3 '16 at 20:36
-1

https://www.youtube.com/watch?v=5DCPDQnRXm8

This tutorial Works Great !!!

1
  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Ghanima Sep 6 '16 at 22:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.