0

I'm attempting to setup a proxy website on a Raspberry Pi 2 Model B. I've tried Simple PHP Proxy and PHP Web Proxy (Sorry I don't have enough reputation to post more than two links). I wasn't successful with either of them. I've done some research and I have found this guide for an Ubuntu server and this guide for linux in general. Currently when I try to connect to index.php on my server I get a 500 internal server error. If I follow the INSTALL.txt that comes with Glype's archive file, it tells me I need to go to admin.php first, but when I do, I receive this:

The settings file for Glype could not be found. Please upload this tool into 
your root glype directory. If you wish to run this script from another 
location, edit the configuration options at the top of the file. 

Attempted to load: includes/settings.php

This error also appears at the top left corner of the page:

Warning: filemtime(): stat failed for includes/settings.php in 
/var/www/html/admin.php on line 66

I've made sure that includes/settings.php exists. I've tried to do things such at putting in the full path of includes/settings.php, putting in the path with root as the www directory, and replacing the forward slashes with backslashes.

1

I got it to work after two days of fiddling. I just moved all of my glype installation files to a subdirectory on my webserver called glype. So instead of everything being in /var/www/html/, its in /var/www/html/glype.

  • For future reference, questions like this are probably better off on Unix & Linux or, if you explain the context is a GNU/Linux system, our larger parent site, Stack Overflow. I doubt any of these things are used only the the Pi ;) – goldilocks Sep 4 '16 at 12:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.