0

The System rebooted after the power supply went off and now it has the wrong date and I cannot use the add ons . can someone walk me the through the solution as I am a dummy

  • 3
    I do not know what " I cannot use the add ons" means. If you wait a few (maybe 15 minutes at most) the time shoud be set by ntp (assuming you are connected to the internet. You could always try restarting ntp if you are in a hurry. systemctl status ntp should give you status. timedatectl will show what time it thinks it is. – Milliways Sep 4 '16 at 8:23
0

I would suggest you to have some script to check the time at the of reboot which is a part of cron, that would checks the ntp status and start it if needed. Also if you need to set right away the time set the time as well.

There is some good article as well on setting up your ntpd stuff here

0

This is a normal issue with RPi, as the clock is not supplied with a backup battery. There's a solutions for that using an addon 'Real Time Clock' board. Read here: https://thepihut.com/blogs/raspberry-pi-tutorials/17209332-adding-a-real-time-clock-to-your-raspberry-pi

0

You need internet connection in order to have valid clock settings. If your clock is not set some time after a reboot, you might have ntpd disabled. In that case, you can simply fix the clock manually by running

ntpdate pool.ntp.org

This will request current time from the server of your choice and set your local clock accordingly.

As a last resort, you can always set the date&time manually using date

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.