I've got a Raspberry Pie 3 (w/ built-in BT), and RetroPie 4.0.2 is installed and working on it. I've got 2 brand new PS3 controllers (I do not own a PS3) and they work with the RetroPie over the USB cable just fine.

I want to get them working over bluetooth, and I've followed all the guides for this that I could find online but really they all seem to follow the same steps. I cannot get the controllers to pair with the Pi! (interestingly though, I can get it to pair with my MacBook Pro... so I know the BT on the controllers work)

Here are the steps I've followed:

RetroPie Setup > Manage Packages > Manage Driver Packages > ps3controller

From here I installed the drivers. My PS3 controller is not currently plugged in. Next I choose Install/Pair PS3 controller and it tells me to connect it via USB then unplug it and press the PS button.

I plug in the USB, the #1 light on the controller slowly blinks, I wait 10 seconds and the I unplug it. I press the PS button and all 4 lights on the controller blink fast and nothing else happens!

From what I've read, what should happen is that I press PS and then the #1 light comes on and the controller vibrates. I've read several forum & reddit posts from other people exactly describing the issue I'm having, but no working resolutions have been provided.

Other Troubleshooting

Nothing has worked yet. Any tips would be a HUGE help for me and other with the same issue!

(cross-posted this question to Reddit's /r/retropie)


See my comment below the accepted answer by @Donny V, but I was able to get this working by using the gasia drivers.

The reason this worked for me was because I accidentally purchased a cheap Chinese knock-off controller! I was able to figure this out based on this discussion on the RetroPie forum. Basically, run the dmesg command and I was able to see the manufacturer of all connected devices. Seeing the devide name of my controller was SZMY-POWER CO.,LTD. PLAYSTATION(R)3 Controller - note that it's not made by Sony!

  • although i was able to follow the steps above in pairing my PS3 remote which is SZMY, every time I restart the indicator shows up as remote 2, and I can't use the remote correctly. Can you please help?
    – R.munoz
    Commented Feb 8, 2017 at 4:58
  • That's a different issue that you should start another question for.
    – Chris Barr
    Commented Feb 9, 2017 at 14:23

4 Answers 4


These directions are what worked for me. Like you I tried everything. Not sure which step cleared it up. But after doing all these it worked, so give it a try.


  1. Shut off the board and make sure controller is unplugged from the Raspberry Pi and your PS3 console is unplugged (don't want the console picking it up).
  2. Plug in a keyboard and start Raspberry Pi.
  3. Start RetroPie setup script in the menu
  4. In setup screen pick "Config / Tools"
  5. Then on next screen pick PS3 Controller
  6. Then pick "Remove PS3 controller" This will take a little bit of time, so just wait until it finishes. Once its done another box will popup, click "Ok".
  7. Now pick Install/Pair PS3 Controller, wait until it's done and a box pops up.
  8. Plug in PS3 controller, wait a little bit for it to pick up controller id. Then unplug controller and press "PS" to pair. The controller should rumble and then select 1.
  9. Cancel out of all the boxes and go back to RetroPie menu.
  10. Hit the F4 key, that will exit you out to the command line.
  11. Type in sudo sixad --start, if it says already started then type in sudo sixad --stop. Now type in sudo sixad --start, press "PS" button for the sixad to find your controller. If it finds it will say so and show its id number and say waiting for input. This lets you know that it found. Looks something like this.enter image description here
  12. Now press ctrl+c to cancel the app.
  13. Type in sudo update-rc.d sixad defaults This will add sixad as a daemon, so that it starts on bootup.
  14. Type sudo reboot
  15. Once RetroPie starts press "PS" button, it should rumble. Then open menu with keyboard to "Configure Input" for the controller.
  16. When the detect gamepad window opens just hold down one of the controller buttons.
  17. You should now be able to configure the buttons.
  18. Done
  • Wow, I really appreciate the detailed directions! Unfortunately I followed them exactly, and I get the same results. Step #8 doesn't connect, and step #11 doesn't either. It times out and says unable to connect to sdp session and HID create error 115 (Operation now in progress) Not sure what to do now!
    – Chris Barr
    Commented Sep 9, 2016 at 1:23
  • You usually get a sdp session error when your not using official PS3 controllers. Like a ShanWan PLAYSTATION3 Controller. github.com/falkTX/qtsixa/issues/4
    – Donny V.
    Commented Sep 10, 2016 at 14:47
  • Hmm, strange ok. I bought them on eBay and they seem to be brand new and in official Sony packaging. I WAS able to pair it via BT to my MacBook Pro and the device name was "SONY PLAYSTATION 3 CONTROLLER" or something like that. They seems to be official to me, but perhaps they are very good fakes. Is there a way to confirm this, or perhaps a way to connect them now that I know this?
    – Chris Barr
    Commented Sep 11, 2016 at 15:42
  • Try "Remove PS3 controller" driver like in step 6 and then try installing one of the other PS3 controller drivers. Keep trying until one of them works.
    – Donny V.
    Commented Sep 12, 2016 at 1:13
  • 1
    I've been busy recently, but I finally got around to this and it now works! Thanks @Donny V. for your input! I was able to pair my PS# controllers using the "gasia only" drivers for some reason. Anyway, they work now!
    – Chris Barr
    Commented Oct 16, 2016 at 18:11

To make the answer obvious for anyone else experiencing the same issues, I followed the steps in Donny V's answer, but that was not working for me.

What eventually did work though was to choose "Remove PS3 controller configurations" and then choose "Install/Pair PS3 Controller (gasia only)"

I'm not sure why this worked since I'm fairly certain these are authentic PS3 controllers... but whatever, it works now. So my advice to anyone else is to try pairing with each of the driver options until one works.

Update: as it turns out, my PS3 controllers were chinese knockoffs (but very good ones!). I ended up selling them and buying real PS3 controllers and the standard setup process works fine now.


This guide totally worked for me.

Basically used the option "Install/Pair PS3 controller (clone support shanwan)" after "Remove PS3 controller configurations" and then the pairing ran smoothly after connect/disconnect USB and hit PS button.

Controller model: CECHZC2M


With the PlayStation you need to have a cable attached from the console to the controller while trying to sync BT. I did that with my Pie setup and worked without any extra code mumbojumbo... give it a try...

  • Thanks, but read above - my problem is already solved. You are correct, this is how one has to initially set up the controllers, however I was unknowingly using a non-Sony Chinese knockoff controllers which required different drivers. They also had terrible battery life, so I ended up buying official Sony controllers which worked much better.
    – Chris Barr
    Commented Feb 16, 2018 at 12:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.