0

I have a raspberry pi connected via ethernet to the router and I have setup port forwarding to work with it on port 80, hitting the apache http server - this works fine.

The problem occurs when I plug in my mobile sim dongle to use as a SMS gateway. I can connect to my raspberry pi locally still on http://192.168.0.11/ for example - so I know it is still connected to the network, but the port forwarding stops working. I know the dongle also has an internal IP address on 192.168.1.1 as opposed to the local ip for the ethernet connection (192.168.0.1).

How could I get port forwarding to work?

  • What port do you forward where? Seems to me you're using the same subnet... – Gotschi Sep 7 '16 at 11:12
  • On the router im port forwarding port 80 on 192.168.0.11 but i've also tried with different ports :( – user1472266 Sep 7 '16 at 11:17
  • 1
    This sounds like the "SMS gateway" is giving your PI a second (or a replacement) default network route, so the answers to the packets that are coming from your router are going out on the GSM network; this will never work. You need to turn off your internet routing over GSM. – user3710044 Sep 14 '16 at 8:22
  • Ahh thanks, I've done a work around of the PI using gets and posts to the server, rather than me calling it and it works great - thanks for replying – user1472266 Sep 14 '16 at 13:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.