I build wifi router for my house in the countryside. I only can have internet via wireless so I buy USB grid antenna and connect on PI and made a bridge to internal antenna. USB antenna is connected to internet provider via PPPoE connection what I setup via pppoeconfig and internal antenna share this network in my house.

The problem is that I can access to Raspberry PI via my laptop but internet not pass via that bridge.

Also I setup static IP because sql and apache server what I need.

How to broadcast internet via this network?

Here is my configuration from /etc/network/interfaces

auto lo
iface lo inet loopback
iface eth0 inet static

address 192.168.1.100
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
#gateway 192.168.1.1

allow-hotplug wlan0
iface wlan0 inet static

address 192.168.42.1
netmask 255.255.255.0
#gateway 192.168.1.1
pre-up iptables-restore < /etc/iptables.ipv4.nat


  # wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
auto wlan1
iface wlan1 inet static

address 192.168.1.100
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
#gateway 192.168.1.1

   wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
allow-hotplug wlan1
auto wlan1
iface wlan1 inet static

address 192.168.1.100
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
#gateway 192.168.1.1

   wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

auto dsl-provider
iface dsl-provider inet ppp
pre-up /bin/ip link set wlan1 up # line maintained by pppoeconf
provider dsl-provider

auto -wlan1
iface -wlan1 inet manual
  • Make sure sysctl -w net.ipv4.ip_forward=1 – kev Sep 7 '16 at 14:23
  • Where to add that? – Ivijan Stefan Stipić Sep 7 '16 at 14:26
  • Run the command as root user in terminal. – kev Sep 7 '16 at 14:39
  • Did you enable MASQUERADE in /etc/iptables.ipv4.nat ? – kev Sep 7 '16 at 14:41
  • Interesting is that iptables.ipv4.nat is empty. What need to be there? – Ivijan Stefan Stipić Sep 7 '16 at 15:15

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.