2

When I try to connect to my Pi via ethernet, it gives me this error:

ssh: connect to host 169.254.76.206 port 22: Connection refused

what should I do and how can I connect?

  • 1
    I don't think that IP address is part of your local network. Check the cables to your switch/router/access point. – kwasmich Sep 7 '16 at 11:28
  • Check your IP address on Raspberry Pi using ifconfig command – Mark Sep 7 '16 at 12:05
  • To be refused means a computer with that IP address has responded so you probably have the right IP in my opinion. SSH may be disabled. If so, enable with raspi-config. – PaulF8080 Sep 7 '16 at 12:28
3

169.254.76.206 is a link-local address. See https://en.wikipedia.org/wiki/Link-local_address

You do not have an IP, and while it is possible to create a limited connect via this on a single link, this depends on a number of factors, including the system from which you are trying to connect.

You need to describe your network configuration.

If you have a router, I suggest you connect the Pi to this.

1

This IP address might not work because it is a link-local address. I don't think that's the one you want (although it might be). When you start up your Raspberry Pi it should show you the IP address you can use to connect to it, which will probably begin with 192.168..

However, your problem is probably that SSH is disabled. Use the command sudo raspi-config to bring up Raspi-Config, and select SSH, then Enable or disable ssh server. This can prevent the "Connection Refused" error you've been getting, assuming you've been connecting to the right place.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.