1

I used win32diskimager to flash an SD card with hard-float Raspbian "wheezy".

When the Pi (a 512MB Model B) is powered on, I get a red light, but nothing happens on the screen (connected by HDMI).

I changed the config file and uncommented some of the lines where it suggests if there is no video to uncomment; there is still no video. I have three cards and none of these are working.

I've additionally removed the keyboard from the USB, to no avail.

What's wrong?

  • Are the three SD cards all different, have you checked them against this list, elinux.org/RPi_SD_cards (or could you list them within your question? (try to elaborate on your question, raspbian(hard/soft), SD Cards used, raspbian image, which tool used to initialise the cards (basically, the more information you can provide, the better the community can help), and welcome to Pi! – kolin Mar 15 '13 at 8:22
  • Power is a common problem when people start using the Pi. What are the specs of the power supply you're using (how many milliamps)? Also, the USB ports on the Pi do not provide the same level of power to devices that other computers do, so you have to be careful of what you plug into the ports on the Pi itself (use a powered USB hub if possible). Unplug all of your USB devices and turn it on... do you get anything on the display? – Jerry Gagnon Mar 15 '13 at 12:43
  • Any green lights flashing? If so I'd suspect the HDMI cable or the monitor. – BobT Mar 21 '13 at 18:45
3

Are you using the hard-float or soft-float wheezy raspbian? The soft-float version seems to be problematic on some Pis. See Soft-float version of Raspbian does not boot.

Another possibility is a problem with the SD card. There have been reported problems with using large cards.

Also, check that the SD card is properly seated in the slot--I had a similar problem when my card wasn't properly connected.

Update: Validate that you have correctly burned the SD card. Do this by mounting the SD card on a windows machine (i.e. plug the card into an SD card reader). Using Windows Explorer, browse the SD card. You should see several files including one called cmdline.txt. If you cannot see such files then you have not burned the SD card properly. A common mistake is to not unpack the downloaded wheezy image. It's delivered as a zip file, so unzip it. There will be an .img file--this is what you want to burn.

Update: Try this troubleshooting wiki.

  • Power Supply; AC-DC; 5V@1A; 90-264V In; Enclosed; Wall Plug; USB; Switching; GS Series – rick Mar 16 '13 at 13:59
  • DA-SD-4096-R SD Card; Flash Memory; 4GB; Class 4 I got these from Allied electronics with the pi kit – rick Mar 16 '13 at 14:00
  • 2012-12-16-wheezy-raspbian.zip using win32diskimager-binary.zip (currently version 0.7) to unpack on win7. I don't know what you mean by raspbian hard or soft. we also unplugged all of the USB connections (for keyboard and mouse), but no difference in boot. – rick Mar 16 '13 at 14:02
  • That version is hard-float, so sounds like a different problem. Soft-float/hard-float here is referring to how the runtime libraries were built by the compiler--do the binaries assume the hardware has support for floating point registers and operations, or does it utilize software emulation, which uses integer registers. The two mechanisms are not compatible so if you run a program with hard float on a soft float system, it cannot use the runtime libraries (and vice-versa). hf vs sf – TheDuke Mar 17 '13 at 18:37
  • I just checked the cards against teh list and truly can't believe it. the cards htat were shipped to us by ALLIED ELECTRONICS, the raspberry pi source were on the list as BAD. Why would they dump this on us and how does anyone expect people to know this when starting out? The quick start documentation says nothing of this and simply following the directions is really not getting anyone anywhere here. Looking at the list, one almost needs to take the list to the local staples store and go card by card, serial number by serial number. truly disappointing. – rick Mar 17 '13 at 22:09
1

You said that you extracted the image from a zip archive with the name "2012-12-16-wheezy-raspbian.zip". This archive holds an older image, and as such is probably not compatible with the revision 2 Model Bs (with their corresponding Hynix memory chips). Read this post on the Raspberry Pi website, and then get the latest version of Raspbian.

  • now we are getting somewhere. I found the 2013-02-09 version. this appears to be the latest. I read the post about the returned pi this morning. The comments distressed me - very unkind. high return rate, though and shows me I am not alone. – rick Mar 22 '13 at 1:46
  • OK! sucess the new version worked. the version I was working with was the one referenced by the quick start guide (pdf link from the quick start guide). Now I see the desk top. thank you so much. – rick Mar 22 '13 at 2:17
  • If my answer worked, then please mark it as "Accepted". – fouric Mar 22 '13 at 2:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.