0

I copied a working image from a sd card (8 Gb) to my computer with the command: dd if=/dev/sdx of=archarm2.iso;sync After that i copied the archarm2.iso image to an other sd card(32G) with the reverse dd command. I built the operating system including an automatic login.

After booting up the new copy on my RPI 3, the boot process seems to stuck in an endless loop at the login prompt. Saying Module is unknown. After this message the login service is stopping and starting again. It says Stopped getty on tty1 and starting getty on tty1 and Failed to start login service. Any ideas what could be wrong or how to fix it?

  • did the image come from a/the same RPi3? – stevieb Sep 8 '16 at 21:49
  • I have a feeling that the image is corrupt. Did you make the image while the Pi is running?! Or did you unplug the card, inserted it on a PC, then made the image there? – PNDA Sep 9 '16 at 7:53
  • I unplugged the card, inserted into my pc, wrote image with dd, and finally restarted with the new image So yes, the image was origining from the same RPI3 – kzpm Sep 10 '16 at 12:12
1

I believe there is something wrong with backup ISO you created. Some important considerations -

  • Your SD card should be formatted using FAT32 filesystem $sudo mkdosfs -F 32 -v /path/to/sd/card

Try doing this -

Step 1 - Backup the sdcard on your local machine

$sudo dd bs=4M if=/dev/sdx of=RaspberryPi_Backup.img

Step 2 - Clone the new SD card with the backup image

$sudo dd bs=4M if=RaspberryPi_Backup.img of=/dev/sdx

Hope this helps. Cheers!!

  • After replacing the sd card with another sd card, your tutorial worked fine. However I think my solution would have worked fine too. I guess it had something to do with sd card state, maybe it was damaged during fabrication or so. Your solution however worked ok so I mark it now as solved. – kzpm Sep 10 '16 at 12:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.