0

I would like to fix a fsck problem I have on my sd card.

I plug it on another RPI using an SD card reader and then I have tried to run fsck but with no success. It seems to repair it but if I run fsck again, the error comes again :

$ sudo fsck.vfat -a -v -w -r /dev/sda5
fsck.fat 3.0.27 (2014-11-12)
Checking we can access the last sector of the filesystem
0x25: Dirty bit is set. Fs was not properly unmounted and some data may be corrupt.
1) Remove dirty bit
2) No action
? 1
Boot sector contents:
System ID "mkfs.fat"
Media byte 0xf8 (hard disk)
       512 bytes per logical sector
      2048 bytes per cluster
         1 reserved sector
First FAT starts at byte 512 (sector 1)
         2 FATs, 16 bit entries
     65536 bytes per FAT (= 128 sectors)
Root directory starts at byte 131584 (sector 257)
       512 root directory entries
Data area starts at byte 147968 (sector 289)
     32183 data clusters (65910784 bytes)
16 sectors/track, 4 heads
    286720 hidden sectors
    129024 sectors total
Reclaiming unconnected clusters.
Perform changes ? (y/n) y
/dev/sda5: 111 files, 10241/32183 clusters
$ sudo fsck /dev/sda5
fsck from util-linux 2.25.2
fsck.fat 3.0.27 (2014-11-12)
0x25: Dirty bit is set. Fs was not properly unmounted and some data may be corrupt.
1) Remove dirty bit
2) No action
? 1
Leaving filesystem unchanged.
/dev/sda5: 111 files, 10241/32183 clusters

Can anybody help me on this issue ?

  • If it does not have any important data I would suggest formatting the card (FAT32) - $sudo mkdosfs -F 32 -v /path/to/sd/card – Tanuj Wagh Sep 9 '16 at 9:07
  • The partition corresponds to the /boot of my other RPI card – Sigmun Sep 9 '16 at 9:10
1

Don't worry about it. This is the /boot partition on NOOBS which is FAT and should not normally be changed, except when doing a firmware upgrade.

The error report is common, and spurious.

0

My suggestion is to fully restore the sd card using gparted (from a linux machine - or a similar partition tool for any OS). Format all the partitions created, make them one again and then re-install whatever you wish.

  • Ok, but I think my SD card is over. I can't modify anything on it, even with dd ! – Sigmun Sep 12 '16 at 13:05
  • If you are sure you haven't made any mistakes formatting and partitioning, then yes. You might have to get another sd card. – Chris Tsiakoulas Sep 12 '16 at 14:24
0

Use SD Formatter to clear the card as this also checks to confirm that the card is not corrupted. If it keeps saying that it needs formatting then it's time to scrap it and start again.

0

Try either:

dosfsck -aw /dev/sda5 (auto repair)

or

dosfsck -rw /dev/sda5 (interactive repair)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.