3

I just bought a wifi dongle: TP-Link TL-WN823N, because it was supposed to work out of the box with the rasberry.

So, I have tried raspbian and now I am trying with OSMC.

First of all, if the raspberry is turned on and I connect the dongle it reboots. But it seems that is ok. So, here we are ok.

But then, booting the RPi with the dongle connected to the USB I got no wifi.
(Note: all the output is the same for my actual os (OSMC) than for the raspbian)

$ iwconfig  
lo        no wireless extensions.  
eth0      no wireless extensions.  

Then, I just check connected usbs:

$ lsusb  
Bus 001 Device 005: ID 2357:0109  
Bus 001 Device 004: ID 046d:c534 Logitech, Inc.  
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter  
Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp. LAN9500     Ethernet 10/100 Adapter / SMSC9512/9514 Hub  
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub  

I know that the guy with no name: Bus 001 Device 005: ID 2357:0109 it is the wifi dongle. But I have no clue how to make it recognize.
I tried this: https://github.com/pvaret/rtl8192cu-fixes
But it doesn't work.

2

Ok. Before I write the post, the quicker I find the solution.

I got the good and functional answer from here: https://www.raspberrypi.org/forums/viewtopic.php?t=148389

Simply, I needed to install the driver. It seems that is pretty new and it is not included in the kernel (even in a lot of places they recommend this dongle to use it with the RPi).

Anyway, in case the link dies, you can get the drivers from here: http://www.tp-link.com/en/download/TL-WN823N.html#Driver

  • 1
    How did you install the driver in rpi ? – forzagreen Jun 17 '17 at 17:04
0

This worked for me with the same device that you are talking about

Step 1: Install the driver using the link:

wget https://dl.dropboxusercontent.com/u/80256631/install-wifi.tar.gz

tar xzf install-wifi.tar.gz

Step 2:Type this to just check the installation

./install-wifi -h

you are good to go.

this has been used by taking help from the link: https://www.raspberrypi.org/forums/viewtopic.php?t=148389

0

This is what worked for me

apt-get install wicd
apt-get update
apt-get upgrade # This may take a little while. Be patient.

wget http://www.fars-robotics.net/install-wifi -O /usr/bin/install-wifi # That's an O not Zero

chmod +x /usr/bin/install-wifi

install-wifi -h

install-wifi # This may take a little while. Be patient.

vi /etc/wpa_supplicant/wpa_supplicant.conf

### Add these lines at the end ###
network={
ssid="YOUR_WIFI_ROUTER"
proto=RSN
key_mgmt=WPA-PSK
pairwise=CCMP TKIP
group=CCMP TKIP
psk="YOUR_PRE-SHARED-KEY"
}

vi /etc/modprobe.d/8192cu.conf

#### Change line to look like this ####
options 8192eu rtw_power_mgnt=0 rtw_enusbss=0 rtw_ips_mode=1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.