2

Every time I boot my RPi, I want a terminal open. I'd love to be able to include that in the boot process.

I'm running Raspian.

How can this be done?

  • Did you mean in the gui? Or do you need to bypass the login prompt? – Eineki Mar 17 '13 at 2:54
  • It could also help to know, what system you are running on your pi (Distro and Desktop environment if applicable) – Max Mar 17 '13 at 10:35
  • 1
    Since it's raspbian, presumably the DE is LXDE, in which case googling "start-up LXDE" might help, eg. forum.lxde.org/viewtopic.php?t=111 I'm not an LXDE user so I can't confirm any of that tho. – goldilocks Mar 18 '13 at 14:53
3

You question does not specify whether by 'terminal' you mean the classic terminal
or a graphical session with XTerm opening up automatically.

I'm going to assume the first.

If you're using wheezyyou can log in automatically by editing /etc/inittab

Search for the line:

1:23:respawn:/sbin/getty 38400 tty1

Add a hash tag in front of it

#1:23:respawn:/sbin/getty 38400 tty1

This will disable the line. Next you need to add a new entry:

1:2345:respawn:/bin/login -f pi tty1 </dev/tty1 >/dev/tty1 2>&1

Where pi is the username of the account you want to use for automatic log in.
Note that this bypasses security, allowing access to your PI without the password of the user.

  • inittab does not exist in stretch – user3123159 Feb 7 '18 at 13:51
0
  1. Make a copy of the file /etc/grub/grub.cong and save it to your home folder
  2. Now open the file using any text editor (I prefer nano) and find the line that says quiet splash
  3. Add text after quiet splash. Now it look like quiet splash text
  4. Save the file
  5. Reboot

If you want to revert, just redo the above steps and remove text

  • I suspect this is off-topic - The Raspberry Pi does/can not use grub AFAICT... – SlySven Jan 24 '16 at 5:22
0

Your question has been answered for if you're talking about just booeting into a tty instead of your DM, so I'll answer how you'd just start your terminal emulator on X startup.

This is just as easy. Edit your /home/user/.xinitrc:

exec gnome-terminal &

and add the above line. Replace gnome-terminal with your term of choice. The ampersand is to make it execute and send to the background so it doesn't lock up X when it starts.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.