0

I am trying to install the library files of I2C/SMBUS on Raspberry Pi. I followed the procedure mentioned on this link, https://pypi.python.org/pypi/smbus-cffi/0.5.1.

The files were downloaded and extracted but i am not able to install it. Attached image shows the error message.

Please suggest solution to this and any other alternatives like other libraries available to get me started.

Thanks in advance.

2

The correct way to install ALL software on the Pi is via the repositories. Always try that first.

sudo apt-get install python-smbus python3-smbus

will install the standard Python I2C/SMBus library (Python 2 and 3).

To check to see if a package is avaialble in the repositories try

apt-cache search search-term

where you need to try likely search terms.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.