0

Recently I bought a raspberry 3, I formatted my sd card, I installed NOOBS on it I got it to my raspberry it was working fine. I plugged a mouse, keyboard and a flash, still working pretty good. But then I plugged an external HDD with USB 3.0(which probably requires too much power). So in the begging, the first five minutes everything was working solid. But 5 minutes later... system crashed. The HDD never worked again on that raspberry (probably because of lack of power).

So, raspberry is working fine for 2 days(I haven't used that HDD in this period) but suddenly system crashes again... I never managed to boot the raspberry again. I am using a 2.5A charger but I tried with 3 other chargers(I don't know their amps), I tried using my brother's orignal raspberry SD card with NOOBS on it and .. nothing.

But his raspberry zero was working just fine with both either my or his SD card.

The ACT led never lights up, while the PWR always does.

Any idea what is wrong ?!

  • if the green ACT LED doesn't light up, it means it isn't able to boot from/read the SD card. Try re-flashing it with the OS again. update: just realized you tried a known-good SD card, so my suggestion may not apply – stevieb Sep 13 '16 at 19:28
  • In the question I said that I've tried on two different SDs, one of which was a original raspberry SD card also both of them work properly on my brother's rasp ZERO – Harton Sep 13 '16 at 19:33
  • You haven't told us anything about the OS on your brother's SD Card, so this is not diagnostic. I suggest you try again with a fresh image. Despite the alleged rating of the PS you are unlikely to be able to run a HD without a powered hub. – Milliways Sep 14 '16 at 10:54
  • rasberry sd cards always run NOOBs, I tried today with a fresh new one but still it doesn't work – Harton Sep 14 '16 at 11:43
0

I think you are correct that the problem is related to power. You did not tell us about the HDD you used. Since you did not mention it having its own separate power supply then I would guess a Passport or something similar.

The maximum power to all USB ports defaults to 600 mA. However, it is possible to edit /boot/config.txt and add or modify the line to say max_usb_current=1 which doubles the amount of power available at the USB ports (for a combined total of 1.2 Amps). Of course, you will want the 2.5 Amp power supply.

Hackaday gives a good explanation of how this works. It is a software change that causes a GPIO hardware change. Here are the hardware details of how power is distributed to USB ports. http://hackaday.com/2015/04/06/more-power-for-raspberry-pi-usb-ports/

Good luck.

  • Trying to overdraw will NOT burn those components, the resistor network is just a configuration 'flag' to the current limit chip. That chip is there mainly to protect the PSU not the PI. However, if you succeed in drawing too much power from the PSU there's no telling what a cheap and nasty PSU might do. I would guess either it's given the PI an overvoltage spike or the disk has put some reverse current flow through the PI and damaged it that way (the PI's USB ports do not have reverse current limitation) – user3710044 Sep 14 '16 at 8:42
  • This is incorrect for the Pi3. See Raspberry Pi Power Limitations. The comment seems to be pure speculation, with little evidence in fact. – Milliways Sep 14 '16 at 10:49
  • It can't be overpowering, the device was working perfectly fine(as I said in the topic) for two days straight without any problem I feel like it's not the HDD.. – Harton Sep 14 '16 at 11:48
  • I edited my post to remove the speculation about parts burning out. It is indeed just a flag. In searching around I cannot find anyone who has burned out a Rpi3 by trying to draw too much power through the USB ports. Perhaps I should instead have simply suggested trying a self-powered hard drive. – SDsolar Sep 15 '16 at 20:37
  • Also might mention that there are gadgets available on the usual places that will show precisely what voltage and amperage is being drawn from a single USB port. One other thing is of concern is the comment about trying various unknown power supplies. Power supply problems can cause a variety of problems. The correct power supplies are inexpensive and some have on/off switches. Also, an earlier comment mentions that if the green light is not coming on then the unit is not even trying to read the SD card. That is spot-on. – SDsolar Sep 15 '16 at 20:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.