0

I have a new Raspberry pi 3 model B and I tried to insert my flash disk so I'll have some extra memory space, and I figured out that it does not fit into the USB port.

I have tried inserting other stuff with an USB connector, and most of it didn't fit in (the only thing that fitted was the mouse-and-keyboard wireless controller, at least). I rather didn't try to insert the flash disk with force, as this could dmamge the computer.

Can anyone help me with this problem?

5
  • Sorry your question isn't entirely clear, you are trying to plug USB devices into the USB ports on the Pi? Why would the devices not fit in the USB socket if they are USB?
    – Darth Vader
    Sep 15 '16 at 18:24
  • 1
    Can you add a close shot image of the USB ports to your question?
    – ott--
    Sep 15 '16 at 20:32
  • Pi case of marginal design? A little work on the plastic the USB ports are supposed to be accessible thru might help. Sep 15 '16 at 23:40
  • 1
    Turn it by 180 degree ;)
    – kwasmich
    Sep 16 '16 at 7:47
  • I believe you probably mean that the flash disk casing takes up too much room and therefore does not allow 4 plugs to fit at the same time or two side by side. If I am correct, you can get yourself a cheap USB extension cord and plug your memory stick or other device in that way. The plug for the extension cord is the same as those used for keyboards and mice. Sep 26 '16 at 3:24
3

The dimensions of a USB A plug should be 12mm wide by 4.5mm tall. You can use digital calipers to confirm that your socket will accept a plug of that size. If it doesn't, you've received a badly manufactured socket and should return the device.

USB A sockets are remarkably sensitive to being restricted by their housing.

USB a socket

In the above image I've circled the flexible tabs used on a common USB A socket. If the socket is inserted into a casing that restricts the movement of the tabs you'll find it incredibly difficult to jam a USB plug into it (as I found when designing wooden enclosures for USB power supplies). If the Pi is in a case, make sure that nothing is preventing these from flexing while you push in your plug. It's just about conceivable that they may have been accidentally bent in towards the centre of the socket opening, resulting in a higher required insertion force. You could try jimmying them open a little further using a small screwdriver. Be very careful not to break them!

The Pi 3 includes 2 separate USB socket modules, each of which houses 2 individual USB sockets, providing a total of 4 sockets. The chances of both USB socket modules being incorrectly manufactured are very very very small. Verify that the problem only exists in one of the dual-socket modules. If you can't fit any of your USB devices into any of the 4 sockets across the 2 modules then the problem is far more likely to be with your insertion method. Assess the way you're trying to plug your devices in and, if it's extravagantly weird, consider reducing any run-up, follow-through, gestural motions, radial arm-swinging, jiggling, shoogling, or unnecessary revolutions.

1
  • Thanks for the advices, I tried something and it worked. But I think it was just badly constructed... sadly. I tried plugging the SAME devices into another pi and it was without a single problem :/
    – Quijibo
    Sep 16 '16 at 17:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.